[Solved] Help with sending an HTTP request

I'm trying to send an HTTP request as a Rule Machine Action:

Example: http://192.168.xx:xx/admin?profile=7&user=admin&xxxxx=xxxxx

The request works fine when being typed in to a browser but does not work through a Rule Machine Action. The logs show the action completing without an error but the result, turning off a camera, never happens.

Im using HTTP PUT and JSON. In The Rule Machine action looks like this: Send POST to: http://192.168.xx.xx:xx/admin?profile=7&user=xxxxx&password=xxxxx

Again, the log shows the action occurring without authentication errors like invalid token, etc.

The crazy thing is that I know this should work because I had it working in the past but accidentally deleted the rule.

Anyone have any ideas?

What device are you sending this to?
I'd suggest you also try it via the Momentary HTTP Switch, so you can rule out if it's your rule that is wrong or something else first.

Have you tried Http Get?

I'm trying to then this request to a Blue Iris web server.

I've also tried using a GET as opposed to a PUT

I've used the Postman app when I have had trouble with HTTP requests.

Thank you @SoundersDude. Your suggested to use the Momentary HTTP switch worked. Still not sure why I could not get the native process working in RE but your workaround was just the ticket. Thank you!

1 Like