[SOLVED] Dashboard Date and Clock tile stops updating date

For the past several days, the Date and Clock tile on my dashboards (occurs on the same dashboard running in multiple places) has not updated the Date at midnight, but the Clock is updating fine. Refreshing the dashboard updates it. Running version Dashboards are displaying using Fully on FireOS.

This may or may not be related to a different issue I am pursuing with my hub becoming unresponsive in the early morning hours with no signs of trouble in the logs. My current theory on that it started when I added the LG TV driver discussed in another thread, but I've since removed it and things had been going better. The Date and Clock tile issue started during that time, but continues after the suspect software was removed and hub rebooted.

Still happening. I created a test dashboard with a Date and Clock template, Date template, Clock template, and Analog Clock template. While the all three clocks continue to show correct time, both the date values stayed the same at midnight. Groundhog Day syndrome.

Tonight I'll try leaving the dashboard running on a PC and iPad to see if the behaviour matches Fully on FireOS.

Mine does same thing and has been that way for some time.

Well, this has now been repro'ed on Chrome on Windows and Chrome on iPad as well as Fully on FireOS, so it doesn't appear to be a client or browser issue. It's weird because it has always worked fine until about a week ago. I'll go ahead and open a support ticket.

1 Like

Yes, I have this problem too. Not sure when it started, although I first noticed it about a month ago. Do please post back here when the support ticket is answered!

I've had the same problem for a while too. Mine is on a Lenovo running Fully. I ended up adding a rule through the Fully client to reload the default page on the Lenovo at 12.15am every day as a workround.

I see someone else started a different thread with this same issue.

@bobbyD Could you look into the ticket I opened on December 30th? I never received a response.

This bug still exists in

It looks like I'll need to do this as well since I haven't got any response on the support ticket. May I ask where you configured that in Fully? I don't see a time-based reload under the Web Auto Reload settings.

It wasn't in Fully itself it is in a rule in Hubitat. I have this driver installed

Fully Kiosk Driver

One of the options in that is to load the default URL page on the device. I run a custom command to do that at just gone midnight. so the page refreshes with the correct date.

I'm tagging Bobby @bobbyD though, because it's very rare that support don't respond so it may have slipped through the net.

I agree with that. I had previously tagged him as well. I didn't want to scream "major bug!!!" because it isn't, and coming out of the holidays is a busy time I'm sure. Yet, two weeks is getting on the unexpected side.

@HAL9000 & @Geoff_T We are looking into it. I wasn't able to reproduce, but I have escalated for further investigation. Thank you for the tag and your feedback.


Strange. I can repro 100% of the time. I've put in an automatic reload on my Fully browser on my Fire tablets to work around the problem on my real dashboards, but I can still repro on both Chrome on iPadOS and Edge on a Windows 10 PC (photo of the Edge repro below, taken just now 1/16/2020). Is there anything you want me to try to help diagnose? I'm now on, by the way.

I've got 3 tablets running and all of them do the same. Date won't update without a refresh.

I'll add my name to the list. I see the same bug with my dashboard using Fully Kiosk on a Nexus 7.

Found a workaround: Created a global string variable (in Rule Machine) called "Today's Date", and then created a rule (also in Rule Machine) to run at 00:01 each day to set the variable equal to %date%. Then display it on the dashboard using a variable string tile.

Well, yeah. Another workaround is to have Fully do a web reload overnight. So we can concede this isn't an earth-shattering problem. But on the other hand, it seems like it wouldn't be that hard to resolve since it is clearly a Hubitat Dashboard issue (not a browser or client issue), and no devices or other apps are involved.

To be honest, I'm moving from surprised to annoyed that I opened a ticket three weeks ago on this and never got a response. @bobbyD


Well, yes, it doesn't sound like it should be complicated to fix!

@bravenel Any chance this can be corrected in the next hub update?

We will look into it.

1 Like