SOLVED: Can't link to shared zwave device via Hub Mesh

Hi - I have Hub Mesh working successfully with several devices shared and working well. I had to reset a Zooz multirelay that was acting flaky. On the non-zwave (C5) hub it was shared to, I unlinked from the device. Then I went to the zwave hub (C7), stopped sharing the device in Hub Mesh so it was local only, then removed the device and did a zwave exclude. Then I reset the device and added it back. All good. I shared it in Hub Mesh on the zwave hub. All good there too.
I went back to the non-zwave Hub (C-5). In Hub Mesh, on the Linked devices tab, it showed as available. I clicked the Plus to link to it, and Hubitat acted like it was doing something, but the device remains unlinked. I've tried this a few times, refreshed the page. I went back to the C-7 where the device is shared from, unshared it and reshared it. Same result - it shows as available, but won't move to the list of linked devices on the C5 hub.

I also tried reconnecting to Hub Mesh on the C5, resyncing, updating. None of these matter.

Edit: Problem solved by rebooting hub. I'll leave this in case it helps anyone else or if it's something support wants to look into.

1 Like

Download the Hubitat app