[Solved] Can't arm away after hotfix

Just installed the hotfix 109 and all of a sudden arm away is gone. I removed my keypads and re-added them to set the option for partial but now Away is gone.


I can arm away from a keypad or from a dashboard. Just not from HSM itself.

I applied the hotfix, removed my Iris V3 keypad and re-added it. This is what I see:


Looks like you have something weird going on there though.

Need to see more of the setup page. Is Armed Away defined? Also, hit the Disarm ... button, then hit the one that replaces it. See if that clears it up.

Yes, Arm Away is defined. I said I can arm away from a keypad or dashboard.

When I disarm, this is what is shown.

Here's the whole setup page.

Anything else?

Disarming and re-arming was the first thing I tried. This isn't my first time at the rodeo.

Could you show me the Application State from the app status page?

I don't know if this is what you mean but there should be a better way to capture this stuff than multiple screenshots. I think that was an ask a year ago.

I tried removing the custom rule for battery and that didn't help.

This is the information we need to debug. It's very useful. We don't have a means of getting into your user interface remotely to look for ourselves.

Would you try something: Arm Home from the UI. Then disarm it from the UI.

See if that brings back the Arm Away button. If not, after you do that I just want to know the value for one state variable: notDelayed. No screenshot necessary, just the value.

Arming home and disarming brought the button back.


Just in case you still want it, notDelayed is True.

Good, thanks. Your HSM was in some weird state, as if it had been interrupted during the countdown for Arm Away. That's what notDelayed being false showed (from your screenshot).

Well, I was testing the keypad last night before the hotfix so it's possible it was. There was some weird behavior with keypads canceling arming but that seems to be all fixed now. I just tried again and notDelayed is correct after canceling arming from a keypad. Weird.

But thanks for your help. And yeah, if you can come up with a better way to grab that hole frame from chrome...it would be a HUGE help. I have a chrome extension which allows select and scroll for screenshots but it doesn't work with hubitat. I still have to make multiples to get the whole settings window. But for the forum for example, I just click and drag and it lets me scroll to the bottom of the page so i can get the whole page in 1 screenshot. Must be something with the way the frames are set up (I obviously know zip about html). If you could build something in or suggest a tool to grab that easier....that would be HUGE!

While fiddling with the keypads, I got it to do it again!! notDelayed is false again.

Can you have a look at the keypad driver, does the state variable exitDelay match the arm away delay value you set in HSM?

Yes for both.

I will look into it. Something's not minding house properly wrt state.notDelayed.

@mike.maxwell is working on it too...I think it might be another v2 keypad issue.

No, it's a bug in HSM. Found it and it's fixed. If you disarm during the countdown, you get this result.

1 Like

Sweet! Well, that's one problem down. :slight_smile:

At least you know how to get around it.

Oh yeah....I was just surprised that I was able to get it to do it again.

Now we know how it happened in the first place.

1 Like