[SOLVED] Bug rule machine

%device% = null instead of device name

This works for me. Is your rule triggering, as opposed to being run manually? The device variable is updated only with an actual trigger event. The UI also does not dynamically update this display, so you'll either need to reload the page after that or see what the actual notification says that is sent to your device.


Thanks, problem solved


Since there’s a solution, can this thread be closed?

Hi there,

I was using the %device% = null to successfully determine when one of my rules is run by being called by another rule (as opposed to being run by a rule trigger event). I just updated to and now the %device% variable is now being set to ‘elapsed time’ instead of null which of course broke my rule.

I have now changed the string comparison to check for %device% = elapsed time which fixes the rule execution. Just concerned that the setting of the %device% variable may not be consistently applied when no rule trigger device is applicable (ie. the rule actions are run by being called from another rule).

Where does the ‘elapsed time’ string come from?