Solved:Aeotec Multisensor 6 Illuimance

tldr: Any reason a multisensor6 reads a large negative number for illuminance, I have bought two and both did the same thing. I have one that works fine.

[Solution: plug it in and let it configure]

More info below
I am trying to setup some sensors under my house to monitor humidity. I first put a Aeotec 6 and it worked great. So I ordered another Multisensor6 and it actually worked well for humidity and temp but the lux reading was always -16000 something. I wanted to monitor the lux setting in case I left the lights on under the house. The first one worked great and I really didn't need to read lux as the other one worked. Seeing how this is a $50 sensor I decided to send it back. I figure I am paying that much, everything should work.

At that time everywhere I checked was out of stock. So I bought a Zooz. The Aoetec was paired to my C5 and the new sensor would need to pair to my C7 due to location. If it weren't for the Zooz not being compatible with my C7 I would have just bought more Zooz sensors. I currently have two on my C5 and they work great. So I swapped the sensors and put the new Zooz on the C5 and the Aoetec on the C7. This has been working well.

I wanted to add a third and since the next one will again need to be paired to my C7 I ordered another Aoetec. Now it is doing the same thing. This one has an lux reading of -32000 something. If no one here has any insights why they would do that I guess I will call aeotec and see what they say before I send back another one.

I have tried the built in and @csteele's drive and they both read the same.

I have quite a few of these and I use only the @csteele version :slight_smile:

I know that if you have a Log tab open on your browser and that if you enable debugging on the Device Info page then click Save Preferences, your logs will explode with info.

The first 50 or so lines are the commands being sent to the MultiSensor... there will be a pause while the device wakes and begins to process all of the commands. Eventually the Illuminance data comes in, looking like this:

dev:845 2021-07-21 08:32:09.938 am info  Illuminance is 0 Lux
dev:845 2021-07-21 08:32:09.935 am debug raw illuminance = 0
dev:845 2021-07-21 08:32:09.932 am debug In multi level report cmd = SensorMultilevelReport(precision:0, scale:1, sensorType:3, sensorValue:[0, 0], size:2, scaledSensorValue:0)

As you can see, for this one I just tested, the RAW value coming from the device is Zero. That's before the driver makes any adjustment/recalculation (ie. to String) The Info line shows the value after calculations. In this case it's the same, no calcs are used in the Illuminance/Lux path. (Lux is a 2 byte value since the range is greater than 255 and thus the max values in a 16 bit signed number is +32768 or -32767. The interpretation I have is that the sensor is defective.

I have one like that. I bought it used, years and years ago, in a set of 5. Eventually I got too curious and took it apart and found that the light sensor, in order to be close to the hole in the plastic, is up on an extension wire on a tiny PCB. Along with the sensor is a resistor and it was missing/broken.

The FCC photos of the internals show it... in the upper right corner:

Screen Shot 2021-07-21 at 8.47.33 AM

I suspect the original owner wanted to clean out the hole with great strength and pried the resistor right off the PCB. :slight_smile:

I simply put that particular MultiSensor in a place where I wasn't planning on using Illuminance and it hasn't crossed my mind since... til today.

1 Like

FWIW I have been using the Xiaomi Mijia Lux sensor for about a year. It sits in my window looking out North. I use it to turn on my accent lights at what I feel is the proper outside Lux.
This device has been solid for me. I can't comment on accuracy but it seems very consistent. Its about an inch in diameter and 1/4" tall.

I mention this only in case you can't sort out the Aeotec 6.

1 Like

Thanks, It did as you show but it's been sitting now for about 20 minutes and has yet to report Illuminace. I will check again this evening. It took several hours before it reported the first time..

Thanks but Lux is only a bonus as I really don't need it, as my main concern is temp and humidity. I guess I will contact Aoetec maybe they will send me one with everything working.

I have a lot of these devices and most are on Battery. To provide the sample, naturally I picked one of my MultiSensors that is on AC/USB power for an instant result. To save battery, obviously, they don't wake very often.

I started the process on one of my (many) battery devices and I'll watch for a response :slight_smile:

maybe I was lucky and timed it when the MultiSensor was about to wake up, but....

dev:755 2021-07-21 10:37:57.425 am info  Illuminance is 0 Lux
dev:755 2021-07-21 10:37:57.422 am debug raw illuminance = 0
dev:755 2021-07-21 10:37:57.419 am debug In multi level report cmd = SensorMultilevelReport(precision:0, scale:1, sensorType:3, sensorValue:[0, 0], size:2, scaledSensorValue:0)
dev:755 2021-07-21 10:37:54.682 am debug ---VERSION REPORT V1--- MultiSensor6D (study) is running firmware version: 1.14, Z-Wave version: 4.54
dev:755 2021-07-21 10:37:54.678 am debug in version report
dev:755 2021-07-21 10:37:54.263 am debug ---VERSION REPORT V1--- MultiSensor6D (study) is running firmware version: 1.14, Z-Wave version: 4.54
dev:755 2021-07-21 10:37:54.259 am debug in version report
dev:755 2021-07-21 10:37:47.864 am debug Sending Z-wave command: SensorMultilevelGet(sensorType:27, scale:0)
dev:755 2021-07-21 10:37:47.860 am debug Sending Z-wave command: SensorMultilevelGet(sensorType:5, scale:0)
dev:755 2021-07-21 10:37:47.857 am debug Sending Z-wave command: SensorMultilevelGet(sensorType:3, scale:0)
dev:755 2021-07-21 10:37:47.854 am debug Sending Z-wave command: SensorMultilevelGet(sensorType:1, scale:0)
dev:755 2021-07-21 10:37:47.851 am debug Sending Z-wave command: SensorBinaryGet()

As you can see, the commands went out at 10:37:47 and the responses came back 10 seconds later.

Just checked the log again and it disabled the debug logging 30 minutes later and then it reported humidity and temp a couple of times, but not illuminance.

I got the impression it was a distance away and not convenient but you can always send the commands and then give the Multisensor a double squeeze to click that internal button and put it into wakeup.

It may be that the Hub times out on pending/unresponsive devices... It's probably a balancing act between ultra sleepy battery devices and detecting dead devices.

I haven't actually put it under the house yet. I learned my lesson on that with the last one. I did try that yesterday according to what I read, holding the action button until the LED turns yellow is supposed to wake it up. It never reported illuminance then either. I just left it over night and it reported a lux reading once at 7:52 the next morning of -32768.

I think I will plug it in and see what that does.

As soon as I plugged it in it seem to start reporting illuminance correctly.

I put it back on battery and I will wait and see if it starts reporting correctly.

1 Like

Still not right I don't think. Sitting in here at my desk it first showed 95 on the battery.
. O then switched back to battery and sat it on the desk and figured it would stay the same as it was still pointed right at the overhead light, but it dropped to 24.

I then watched it and it rose to 25 at the next 5 minute interval and stayed there for the next. I then moved it out in the garage facing a outside window. It jumped to 191 and it has been climbing ever since. It is now at 449. It is fairly cloudy today.

The Zooz sensor in the bathroom shows a lux of 35, also near a window. I will leave it over night and see what it does, I have it setup on a hubigraph time graph.

These values don't seem correct? I went back and looked at the sensor under my house and when I turn on the light it shows a lux of about 40.

The manual says that the Battery vs USB is detected at Include time... yet both of us have seen some elements of it work even when it's on the opposite of what it thinks. I have updated to v1.14 Aeon Firmware by using USB power, without excluding them and obviously not re-Including them. I think I did 11 of them this way. I know I upgraded one in-place, still stuck to the wall with a USB wire going inside, but I had to remove power to reboot it, so if I remember right, I did the other USB ones by taking them off the wall and back to my "bench" then putting them back on the wall, since doing it in place wasn't making the process quicker.

@terminal3 - I posted this in another thread but there is a new firmware version out that may address invalid readings.

V1.15 Changelogs:

  • Fixes Light Sensor reporting abnormal values on occasion

V1.14 Changelogs:

  • Basic Set faster report trigger when motion detected (when Parameter 5 [1 byte] = 1)
  • Support new hardware light sensor Si1133
    • Backwards compatible to older light sensor Si1132 (used in firmware V1.13 and under)

Thanks for the info. This unit currently is running 1.14, the one that never gave me any issues is on 1.12. After a couple hours the lux reading are as shown in graph below. The red is the Aoetec and the blue is a Zooz sensor. Both sitting in rooms with windows measuring ambient light.

As I said I don't really need the unit to read illuminance I just didn't want to pay full price for a sensor that was defective. I will see what it looks like after a day. Interested in what it shows tonight when it gets dark.

1 Like

Looks like it is working, just need to plug it in for a minute. I didn't do that with the first one, and perhaps the one I sent back would have worked had I plugged it in. No instruction seem to indicate you couldn't configure from a battery.

Apparently the Zooz and Aoetec have different standards of Lux measurements.

Wait til you see what the UV scale is :slight_smile:

I believe the range is 0-12, because limits are 1-11. That means that the value is not a measurement. The sun puts out approximately the same energy in all frequencies and thus Lux and UV should be the same scale. The atmosphere affects UV more but to have it be 1/1000 is funny to think about. Clearly they are scaling the value to be "The UV Index Scale" and that's OK but they never quite say so.

Just had the sensor that had been working since I installed stop reporting. I notice my humidity graph was not updating and saw the sensor had not reported anything in about 24hours. Went looked at the events page and the last thing that was shown was a notice that a new version was available. Then nothing.

Went up under the house and took a plug with me plugged it in and it started back working . I hope this not something I am going to have to do on a regular basis.

I've never experienced that phenomenon. A large set of my MS6 are battery based, as evidenced by the 10 sets of CR123 in my battery drawer. I should have seen this at least once given the time I've had them. :slight_smile: So far, zero and that's a number that I'm not hoping to change. :smiley:

I guess I could see a situation where the radio strength is just on the edge... the battery dips, or a pet lies down in the path between the sensor and hub/hop and it doesn't have an alternate path.. it gives up. I'm not saying this is true.. just inventing a story that weaves through the clues.

Download the Hubitat app