SNZB-01 Driver

Why is it that when I use the driver from Oh-La Labs everything seems to work fine on the Sonoff Button. But, when I use the native driver, the button is paired and clicking on the command for push or hold shows up on the event list, but not double tap. Moreover, an actual button push does nothing. Let me be clear, a button push, hold, or double tap does not show up in the events for the native driver, but does for the O-La driver. I read a number of posts indicating that the native driver worked fine for this Sonoff Button Controller...so why not for me?
Larry

I have 2 of these and I use them to turn lights on/off. Push to turn on, push again to turn off. Not using any double tap. I have zero issues with the built in driver. If it was mine, I would try removing and incluing the button again.

I'm sure someone smarter then me will have some additional (and probably better) suggestions for you.

1 Like

After you click save on the device page, are you clicking configure?

2 Likes

@lsbrodsky

What @rlithgow1 said. Also, when changing drivers (especially from an Oh-La Labs driver to a native driver), it is a really good idea to first change to the "Device" driver, and click "Delete All States" and "Delete All Scheduled Jobs".

Then change to the native driver, and then click Configure as @rlithgow1 suggested. Then wait a few minutes before using the device. I would also recommend having the device close to the Hubitat while clicking Configure and for a few minutes after that before moving it to its final location.

2 Likes

I always forget about that bit... DOH!

2 Likes

I did click configure but I will try again implementing your advice above. I am configuring this device with it about 2 feet from the hub, so range is not an issue. I was also puzzled by the fact that the double tap did not result in anything on the event list when clicking on that command, separate from the fact that a button push did nothing. I did re-pair the device, no joy. The user driver does allow the double tap to work.

OK, trying, but how do I change to the device driver and delete all scheduled jobs and delete all states? I see no boxes for that under device and the driver is under type, but the user driver is already selected with no options other than another driver.
Larry

"Device" is an option under driver. It is the name of the driver.

1 Like

As @aaiyar driver is the name of the driver. So on the device page click the driver drop down the type the word driver and it will show. Click it then click save

1 Like

Yeah, sorry. I am on that page but I am not seeing the options you mention, Initialize, refresh, release, hold, push, force recovery mode, reset restored counter, etc. The drivers are listed under Device Information, the TYPE. I have switched to the system driver, without the deletions you recommend and the Push and HELD physical are now working, but not doub;le tap. OK, I do not need double tap.

@lsbrodsky
Under the physical device:

Change driver in drop down to "DEVICE"

image

Click Save then the options will appear

Change driver back to original, click save then click configure.

So helpful!!! Many thanks. I was not tuning in on Device in the driver(type) box. Done Strangely, double tap does not work either digital or physical with the system driver.
Larry

Well I would continue using the community driver if that's working for you. There isn't really an advantage of using the native one over it. I use the community one for my Sonoff humidity sensor.

1 Like

Maybe a good idea, although I am on the system driver now and it does what I need. I wonder if the system driver stays more updated.

That's actually handled by the device reporting, not the driver.

What driver are you using? What is the type?
I just bought one and all I see is the Sonoff Zigbee Button Controller.
Not working.

Stevenr

That's the driver I'm using with mine and they work great. Never miss a press.

Maybe yours didn't join right or your mesh is weak and the hub can't see it?