Smoke alarm went off, HSM didn't perform

Yes. And also refreshing again a little while later to see that it disappears.

And look at App Events again (refreshed). Below is from my system, running production version of HSM.

That looks nice... How can I get mine to do that? :slight_smile:

What release are you on? There was a bug with smoke and water alerts not being rearmed after Disarm All was used. I think the fix for this was pushed out in

I'm on I just tried disarming all and re-arming on the offchance, but no go. Should I try removing HSM and rebuilding it?

Before you do that, show me a right now current screenshot of HSM main page, for the smoke section. Like the one you did first above.

That's the apps list. I mean the app itself.

OK, good. Last thing, please show me the Application State from the lower portion of the App Status page.

Interesting. All of that looks normal. One thing is clear, it's never had a smoke alert go off since you installed it. It's never been fired by a "smoke detected" event. Yet your system threw those events.

Your Event Subscriptions were as expected, but if one had gone off, it leaves bread crumbs in state. I don't know why that isn't happening.

You could rebuild it, or first you could try just opening it and hitting Done. That would redo all of the event subscriptions. But so would some of the other things you've done. It's baffling to me why it is not seeing the smoke events.

Okay, believe it or not I just removed HSM entirely and then reinstalled and rebuilt it exactly as before, and that did not fix the issue... Still testing with the virtual omni sensor.

One other thing. Did you look at Logs? They would show if some error were thrown somewhere that could explain this. What I'd do is refresh the Logs page, so it's blank. Then flip your virtual smoke detector to clear and then to smoke detected. Then look at the logs. You should see the smoke events, and any error would show up.


Don't know why it took me so long to look at the logs, lol.

Sorry to butt in here but wasn't pulled? Perhaps might be worth a try?

If you don't mind I'm going to go ahead and remove all the screenshots of the inner workings of my security system now. :+1:

No problem. Ninjas have already been deployed :stuck_out_tongue_winking_eye:

1 Like

Well, that explains it. Sigh. Now to figure out why,,,

I'm pretty sure it has to do with the Lights alerts. But, have to investigate further. Thanks for your help. Will get to the bottom of this and fix the bug. I'm pretty sure I know what is causing it...

1 Like

Sorry to jump in here. But I just tried the same thing with my system and the lights flash part did cause an issue. Selecting some of the lights (dimmers) caused the speech not to work and the dimmers did not flash. So I removed the dimmers and left the light switches that were the on/off kind and it worked and the speech came through. Hope that helps.

Yes, the bug has to do with capturing the state of some of the lights. In the OP case, I suspect it's the LIFX bulb that's causing it. Irrespective, I know what the bug is and it will be addressed.

My LIFX bulbs were part of the issue too as well as a zooz dimmer.

Where did you see this. My hub would not find this update last night. Makes sense now if it was removed.