Smartthings Zigbee Siren

Looks like a standard Tuya device. See if this works?[RELEASE] Tuya Smart Siren Zigbee driver?

Hey @rocketwiz thanks for the message. I tried this driver as well, but I could not manage to turn on the siren. The strobe worked for a few seconds, but no siren. I don’t care about the strobe, but the siren I need for my security routines.
It was really easy and straightforward to pair it with Smartthings and I was hopping to use it with HE as well.
They are great sirens and really affordable.

Any other ideas ? I’d appreciate.

Try resetting and re-pairing the siren, while pairing grab a screenshot of the info and post it here.
Should be something like this:

TYST11 -d0yu2xgi- ZigBee Siren info

With the fingerprint it may be possible to add your siren to an existing driver.

1 Like

Hey @Ranchitat thank you. This is the pairing info I got

You might need to go to Hub owners - Hubitat , join the group and then you'll be able to post pics. :grin:

1 Like

Just fixed it :stuck_out_tongue:. Please have a look on the pic I posted.

@Ranchitat does that make sense to you?

Hmm, doesn't look good. :slightly_frowning_face:

Does this match what you have?

SZ-SRN12N Siren link

That’s the one, yes. I saw that post, but there was no reply.
Damn, seriously.. I’m getting frustrated. I have these 3 sirens in different points of my house and I hate to think I won’t be able to integrate them, even they being Zigbee. :rage:

I don’t get why the Generic Zigbee driver won’t work.

Sorry, not much more I can do.
But in case someone more knowledgeable comes along... @kkossev
Here's a link to the deconz thread that may be helpful. :man_shrugging:

Try this?

This siren, although based on Tuya SoC uses the standard IAS zone cluster 0x0500 and IAS WD cluster0x0502 for control, it will not work with the Tuya-specific drivers.

Sercomm SZ-SRN12N could work with some of the Hubitat inbuilt drivers, have you tried the Frient Smart Siren for example?


1 Like

Hey @kkossev I will give it a try and let you know. Thanks for the tip.

Also remember that anytime you change a driver, after you click save, you MUST click configure..

1 Like

@kkossev and @rlithgow1 I tried the "frient Smart Siren" driver, but it didnt work either. I also clicked in CONFIGURE, as you said @rlithgow1 but nothing afterwards.

Any other driver that can potentially work with Sercomm SZ-SRN12N? Worst case I will get rid of them and replace with Aeotec Siren Gen5. I did not plan to replace so many devices when transitioning from ST to HE :frowning:

I appreciate everybodys inputs. I was not expecting a lot of help honestly, but you guys were kind to suggest some ideas to solve my issue.

1 Like

Probably @mike.maxwell can help, here is the Sercomm SZ-SRN12N detailed info.

@mike.maxwell I’d appreciate any insights. Thanks

unfortunately this isn't anything i can look into right now.