Smartlife RGBW Controller setup

In Google Home parent device is not present, I guess because google does not see it as incompatible. Can't even select in in Google hubitat app.
In Alexa parent device works fine, all child devices are present, but Alexa won't child devices with voice. Just telling me I could not find the device called .... However, and that is really puzzled me, I can control all child device from Alexa app manually. Parent device works fine in Alexa app with voice.

Ahh, maybe it's due to the naming being to close to something else and Alexa can't figure it out by voice? Just for clarity, are you using the Amazon Echo Skill app? Or the original version Amazon Alexa App which is was isn't as flexible as the newer Amazon Echo Skill

I am using Amazon Echo Skill. Was using same skill before with original H801 driver. With original driver, everything worked well. I even removed all devices from Alexa and added them back...

Well, I am out of suggestions other than trying posting this in the forum for the Amazon Echo Skill integration. I think it has something to do with that app more than something to do with @ericm driver. I made him aware of the situation by the way just in case it is on the driver side.

As far as Google Home integration I haven't started that migration process yet.

I don't have any issues that you are having.

Some things you need to know:

  1. The child device ONLY activates the program. It does NOT turn the H801 on/off
  2. The Parent device is the ONLY way to turn off your programs

I have a device called TV-RGBW with child program accounts called TV-Program 1, ...6. If I say "Alexa, Turn on TV-Program 6" my lighting effects go on and continue. If I say "Alexa, turn off TV-Program 6" nothing happens. If I say "Alexa, turn off TV-RGBW" the lights turn off.

Using latest code for both app and drivers. No issues.

Actually depends on program, it does turn on. H801. Turn off child, stops the program, but does not turn off H801.
I will try to rename child programs once more, but that is strange because I had same name since ST.
But, are you able to control main device with Google home?

I haven’t tried Google Home. I have a device and will give it a try later tonight. Works with Alexa though.

I think there is something wrong with Alexa from Amazon side. Removed Philips Hue skill from Alexa app completely and yet Alexa will find all my hue lights and scenes. For H801 child devices, I could not use any device name that I had before with old driver, had to come up with complete deferment names otherwise Alexa would answer "that device is not available", but would control same device manually.

Google Home worked too. No issues with current drivers and app.

I think I was completely confused here. Just to be clear. You are referring to the child programs of the Actions Programs not the child devices of the output channels? Sorry, I was referring to the new child devices of the H801 channels that @ericm just released not the special action programming. I am not using those in Alexa.

Where is that at? I think I may have to load a newer version of the H801 firmware. :grin:

1 Like

I also tested Google Home. Everything working there. Not sure what would be up with Alexa, but from a driver point of view there isn't much that could be wrong.

You are right about the programs. Turning off a program child device stops the program from running but it doesn't turn off the LED strip. If you have the strip flashing red and blue with a program and turn that program off it will stop cycling through red and blue and stay on whichever color it ended on.

Not sure what I do wrong, But if I select parent device in Hubitat Google home app, it gets removed by application. Child devices are fine.

Do you have the latest Hubitat firmware installed? The latest H801 drivers? I just removed my devices from the Google Home App and readded the parent and child devices:

Also, are you resyncing the devices after adding or removing them? Say "Ok Google, resync devices".

Yes, the latest Hubitat firmware and the latest drivers. Tried to resync with Google. Still same error.

Latest H801 firmware too?

Where are the firmwares?

They are in the drivers section of @ericm github.

1 Like

This has been working flawlessly until now. For some reason my lights just won't turn on when being used in RM4. I can go into the lights under devices and select White1 ON and they will turn on. But when I run the rule to turn on the switch it says that it turned them on but they don't go on. I am not sure why they have all of a sudden stopped responding. This worked yesterday. I am not sure why but my lights don't turn on or off when I press the "ON" or "OFF" buttons in the device.

Edit: If I press on White1 ON button, it will turn the light on. Then I can turn it off or on using just the ON Button or the OFF Button in the devices pages. But they still won't turn on using the rule in RM. It also seems that also after I have ran the rule and the lights didn't turn on I have to go back into the devices page and press the White1 ON button again to turn it on as it won't turn on with the ON button.

Download the Hubitat app