Smart lights and modes broken every day after a power outage

This may just be a bugreport instead of support.

We have had more snow than ever recorded in history here in Boulder Colorado (true story as of today) and lost of power problems.

I keep waking up to all the evening lights being turned on and mode stuck at evening. I'm pretty sure my config is correct and it's a bug but here are the settings. Lights are on and mode is evening. This happens every time there is a power outage.

Have you tried soft resetting then restoring from backup? Similar thing happened to me, my RM and ML broke after a power shutoff. Soft reset helped me.

You really should be running your hub on a ups.


Modes don't just switch when the power comes back on. They look forward in time rather than backwards. They are scheduled to happen at certain finite points during the day, and you should get back in synch when the next scheduled mode occurs. It has no way to go back and figure out where it was supposed to be, so it stays with where it was when the power goes out.

I didn't like this mode model, so I did some scheduling in Rule Machine instead. It switches modes by checking every 15 minutes whether we are home or away, and whether it is sunset, sunrise, day, night, or whatever. My rule can reset the mode if it is in the wrong place.


Another thing you can do is instead of using mode manager define your modes time changes in an RM4 rule.
Then define another rule to run the actions of your 'modes' rule after a system start.
This will ensure you are in the correct 'mode' after a hub reboot/restart/power on.

1 Like

These are good solutions and suggestions. However I think Hubitat should change their App to not just add a timed job that is lost on power outage. That's an implementation limitation I don't want to to worry about.

If you don't, change the checkbox to be honest and say:
"Also turn off at sunrise, unless there was a power outage"