Smart Implant not updating or accurate temp

Good Morning.
This week end i connected a Fibaro Smart implant FGBS 222.
Bought some DS 18B20s from amazon.

It looks like the wiring diagram on the probe is:
Red ( VCC) is power
Yellow is Data
Black is GND.

On the smart implant, the wiring is
Blue - GND
WH - Data
Brown - Power

I have then connected as such

Blue ( GND)…..Black(GND)
White (Data)….Yellow(Data)
Brown (Power)……Red (VCC..power)

I have the implant connected to my Hubitat. I can see the internal temp on the implant…and it changes as i warm or cool the implant

The 2 relays on the implant are operational. I can control them both with my HE
Im pretty certain the implant is at least connected to HE and i have control.

The issue im having is i cant get the temp on the eternal probe to change. It is stuck at 68 degrees…regardless of me cooling it ( ice water) or heating it ( palm of my hand)

I was looking at Smart Implant posts here and i see there was a new driver. I downloaded package manager and updated the new user driver....but the probe is still stuck on 68 degrees.

Ive swapped i bought 5 of them and no difference.
Could be an HE issue. though i believe i have it configured it right and ive tried a new driver.
Could be a probe issue…but i have changed between 2 of them….
Could be an implant issue.

2 questions.
Anyone know if decently priced, reliable DS18B probes? I don't mind buying more.
Anything else to suggest? If i swap to a different brand of probe - im thinking i might have to send the implant back if no other remedies.


You have the wiring the same as my 222's. Check on the reporting freq and Delta's
I got mine from AArtech as the had 3M ones and a guarantee.
Power supply >9VDC and on mains not battery?
Download the online PDF from Fibaro for a better manual.
I'm using @christi999 driver but the built-in one worked as well.

**Internal temperature sensor - minimal change to report:3
**Internal temperature sensor - periodical reports:3600

Just making sure... The probes need to be connected to the implant before it is joined/included with the network.

Thst might have been the issue.
I connected the implant before the sensors arrived.
I excluded the implant. Re paired it snd it seems to be working now. It defaulted back to the fibaro driver.
Only issue now is the temp reported in the logs and the temp from the device in my dashboard are off by 10 degrees. Odd but getting closer to working.

Question please.
I’m planning on adding a total of 3 sensors. Do I need to exclude and rejoin again when I add or should it pick the additional ones up?


You need to exclude and rejoin.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.