Smart House + Power failure = Dumb House

So I made it through Friday’s nor’easter unscathed only to lose power at 11:00 AM this morning. Finally was restored by 3PM and I spent about an hour getting things back online. A few observations:

  • A broom handle works well to jam in the track of your garage door, should you discover that the cheap Home Depot replacement door springs that worked so well a few years ago are now too stretched out to keep the door open when its disconnected from the electric opener.

  • The UPS I thoughtfully attached to the Hubitat and router was a great idea; disabling wifi on that router (to prevent interference) and running all my wifi on another access point (unattached to a UPS) was not.

  • About 5 minutes after power was restored and my ST hub and Hubitat were back on line, all the devices that would have produced audible alerts during the outage (exterior motion sensors, mailbox door open, and freezer temp alert) sounded off in a steady stream one after the other. Apparently the battery operated zigbee devices can queue up commands when the hub is offline and they eventually can get retransmitted hours later.

  • My Z-Wave Aeon Water Sensor was declared prematurely “DEAD” in Z-Wave settings. There was a ‘Ping’ button (never saw that before) displayed under the Re-Initialize button. I tried both Ping and Re-Initialize and also ‘Updated’ the screen; the Aeon was still pronounced dead. What revived it was putting water on the sensor probes. It immediately triggered a ‘Leak’ automation as it should have, and the Z-Wave settings screen was then persuaded it was ALIVE.

  • There must be some magic sequence required to restore the Hubitat and zigbee repeaters after an outage to get things working again. While (incredibly) the zigbee stuff attached to SmartThings all functioned without intervention when power was restored, about half of my zigbee devices on Hubitat remained uncontrollable. Power had been restored at least an hour when I got around to fixing things, so it had enough time to come back on its own if it was ever going to.

I tried the easy stuff first: power cycled a couple of smart bulbs, re-plugged an Iris Smart Plug repeater; made no difference. Oddly, when I looked at the Hubitat device screen for a non-responsive Iris plug while operating the plug’s local on/off switch, Hubitat immediately showed the change in on/off state (and power), yet could not turn the plug on or off from the web interface. Commands were being correctly routed from the remote device to the Hubitat (it reflected the change in state due to local control) yet its outbound commands from Hubitat were not being received.

Before giving up and rebooting the Hubitat, I did verify (via XCTU and my Digi XStick) that all zigbee routers were online and had active links to the Hubitat. So I finally rebooted the Hubitat; immediaely all the Zigbee stuff worked again. I’m disappointed in that, because that means if I was not home to do it, and had no remote means of rebooting the Hubitat after power was restored, that my zigbee network would remain non-functional without manual intervention.

That's not good indeed. Full unattended recovery is required for reliable security self-monitoring. I was concerned about this because Hubitat strongly advises manual shutdown, so I had emailed with support about that. They assured that the hub is designed to recover by itself where it was before the outage. A database corruption would be a rare event. I've tested the hub by yanking out the cord a couple of times, and it always recovered safely, but I have only a few zigbee devices. Your post makes me concerned again. It does not seem like you had a database corruption. They told me that a corruption would result in a non-responsive hub. So something else must be going on in your case. I would like to hear other's experiences with this as well.

This is a year later. There have been a lot of platform changes to the way the database is structured and recovered.

1 Like

Agreed... that was back in the early days. I've had a few power failures since then and nothing drastic was needed to recover (and even in that early scenario, no database corruption happened AFAIK; the restart was the only recovery action taken).

1 Like

Can you elaborate what kind of problems you had that required a restart? I expect it to recover consistently with no restarts, otherwise you cannot rely on it for remote monitoring.