Smart door opener

Hey there,

I'm getting frustrated... I've tried to make my door opener smart and right now, I'm getting nowhere. It is a really simple mechanism. A switch with 14 V AC, when it's closed, the door opens. Just bridging L and N with a cable works perfectly fine. I've tried the shelly UNI, connected to 12 V AC, but no matter how I connect it, I just can't make the door buzzer smart. Has somebody an idea or could someone tell me, how to connect it? Do I need a stronger power adapter? A fun project for 20 Minutes turned into a nightmare so far...

Do you mean garage door opener or Do you like live in an apartment building that buzz's people in?

Apartment building to buzz people in

Zen 16 might work out in this instance (or a zen17)

I'll keep that in mind, but there has to be a solution with the shelly.

@aaiyar You do shelly stuff don't you?

I use a Shelly Uni as a garage door opener with no issue. What have you tried? Which driver are you using?

Not for this.

2 Likes

These are my wiring attempts so far:


I didn't even get to the driver part, yet. Right now, I'm trying to get it work with the shelly app, but I already got a community driver from tomw.

1 Like

Here’s how mine is connected:

With an actual picture:

That said, since I have a newer Chamberlain opener, I had to solder the cable that you see coming out from the box on the right to the button on my opener for this to work.

For the box, I used the “box” from an old AC/DC converter plug that was no longer working. I removed the guts from it and replaced them with the Uni.

1 Like

This is basically, what I did first... I don't get it...

1 Like

So it sounds like you did everything right… From the app, you can switch the relay to closed and open with no issues? Have you tried a resistance meter on the black cables to make sure that it properly made the required contact?

Oh, and you are using Direct Current, not Alternating Current, right? (I think also that the polarity is important - as long as the red light turns on and it is accessible in the app, it should be okay).

So, rewired everything. The shelly is accessible in the app. So far so good. When I measured after turning on the shelly, recognized a voltage drop of 1V. As mentioned before, on my door buzzer I could measure 14 V, my shelly is connected to 12 V. Could this be the issue? And if so, would a stronger power supply solve this issue?

Ok, got through several threads in the shelly forum. So, I'm an idiot. Why? Let me walk you through it:

  1. I used the wrong power supply. I was sure to use an AC supply, but I used DC. In and of itself, not a big deal, if there wasn't point No. 2.

  2. If the Shelly is connected to DC it can hardly switch AC. I still don't get why, but this seemed to be the problem.

So, what's next? I'm getting myself an AC power supply and see if this changes anything. I'll hope for the best and keep you guys posted.

1 Like

So if I understand, you need it to feed 14V AC to your buzzer?

If so, then the 12V DC should remain as is on the Red/Black cables.

I would think that one end of the 14V AC should be connected to one end of the relay and the other to the return of the buzzer. Does that make sense?

What I have is an opener, so it only needs to connect the two cables together temporarily to open the door.

1 Like

It does, totally. But what seems to be the problem, is that the shelly uni doesn't like to be connected to DC, while trying to switch AC. At least that's what I figured out while going through several threads at the shelly community.

Same here, that's what drove me crazy...

Let's see if the AC-Power supply that I've ordered will make any difference. I'll keep you posted.

1 Like

thats your issue

It cant / shouldn't have AC connected to its outputs

saying that it then says this!

Ok, the AC power supply wasn't the problem either... And I just don't get it. What bugs me even more, is the fact, that as soon as I wire the shelly to my door buzzer, it's not buzzing anymore... When it's removed, everything works fine again. And again, pure confusion...

So thinking about doorbells, they require an inline resistor in order to work. Without seeing your setup I figured I'd throw that out there.

Possible... I honestly have no idea... :no_mouth:
I'm going to make a picture tomorrow and post it here. Let's see if anyone has a clue. So far, I'm out of ideas how to control it with the shelly uni and thinking about building a little robot, that pushes the button for me. Like the switchbot.

Download the Hubitat app