Slowdown when HE cannot talk to WAN

I have at least one issue which may be causing another, but I'll mainly deal with one that has more clear evidence.

I noticed that my zigbee lights (Philips hue bulbs) only come on 50% of the time given an app that turns them on at a certain time in the evening and turns them off in the morning. I thought maybe the HE needed a restart, so went to Settings and restarted. After it came up, it took 10 seconds for any link to resolve in the HE web interface. I had a hunch this was due to HE trying to reach the WAN but not being able to because I blocked it at the firewall level. I disabled the firewall rule for one second, and everything in the web interface was fast again. Is there a way to fix it so that HE does not need a WAN connection and to make external connections in order to function?

The hub needs access to a NTP server on reboot, if you have one in your LAN (on an always on PC) there is a community driver to make the hub use a specific ip.

Thanks for the tip on the NTP server.

It really should be an option in network settings, though it technically shouldn't have been an issue anyway since my DHCP server also sets NTP for the clients.

I installed the custom driver for NTP and restarted with the firewall up, and I still have the same issue.