Sinope TH1124ZB

I have a couple of 4kW myself but haven't seen a difference between them and my multiple 3kW ones. Odd that you are seeing something different...

Using kris2k2 driver from https://github.com/kris2k2/hubitat/drivers/kris2k2-Sinope-TH112XZB.groovy

I struggled with this one almost daily. 1 random thermostat somewhere in the house would suddenly have the time go blank. @mbeaulieu32 was experiencing the same thing. This would happen with both the built-in driver as well as the modified driver. I had to setup a rule where once per hour it would "configure" every thermostat in the house. I still had issues where I would set the temperature and the thermostat itself would show the correct set point but the driver and the dashboard would still show the previous set point until I did a "refresh". So I had to setup another rule to constantly refresh the thermostats. It just got messy.

Ultimately I ended up moving these to zigbee2mqtt on a conbee ii stick in early September and it completely solved both issues I was having. Right now z2m can be brought into HE through an mqtt add-on or through node-red. These devices are also supported on Deconz with the conbee ii stick, which can then also be brought into HE through a deconz custom driver or node-red. So there are options out there

Looking at my zigbee route table. That thermostat has the lowest LQI even though it's closest to the hub. Not sure if it's related but I am going to rotate my hub a little to see it will help. If not then I will swap it to another location.
Clock went blank again this morning. Weird.

LQI:242, age:4, inCost:5, outCost:1

If you've got an LQI of 242 I guarantee you that is not your issue. If I'm not mistaken the maximum LQI value is 250 or somewhere in that vicinity.

Max is 255. It's the only device in my mesh with the lowest LQI.

New version of the driver for TH112XZB (3KW and 4KW).

  • Clock Display/Hide logic has been inverted. Now the preference setting is Hide the Clock and it's false by default. This might help if you have the clock disappearing on you. I am suspicious that maybe some preference settings lose their values between execution. I have no proof of that, it's just a theory. Anyway probably 99% of us want the Clock displayed all the time so it make sense to invert the logic.

  • Added 24h / 12h AM/PM preference settings. Default value is 24h.

  • Added the unit measure when event are send. This will add °C or °F in the thermostat dashboard or in the event log. Also W (Watt) for the output power.

image

  • The thermostatSetpoint attribute is now set at the same time as the heatingSetpoint. I had an issue with Google Home not reporting the correct setpoint of the thermostat and I realized that these 2 attributes needs to be set together. It's done this way in the Sinope SmartThing driver.

Again, this is based on @kris2k2 driver and I am just adding/correcting things that I think are useful. Most of the hard work as been done by Kris.

Don't forget to hit "Save Preference" after you update the driver.

https://github.com/erilaj/hubitat/blob/main/drivers/Sinope/erilaj-Sinope-TH112XZB.groovy

3 Likes

I ordered the GT130 based on Sinope support's communication where they stated that by connecting the thermostats to the GT130 gateway they would automatically receive the firmware updates.

It arrived yesterday so I moved my kitchen thermostat and my storage thermostat over right away as a test. At some point overnight they both updated, but it was the software not the firmware. Both thermostats are now on software version 0.6.4. My kitchen thermostat is still on firmware 1723 and the storage is still on firmware 1573. As a point of reference, the new ones I just received are on firmware 2007.

The kitchen thermostat still does not display the word "Out" under the outside temperature.

For me, the TH1300ZB driver from 2 days ago broke the clock. Whatever I do, it doesn't show up, while the previous version worked. The HE driver does restore the clock though but as soon as I put @erilaj 's new driver, it disappear.

Is that the version with the preference setting "Hide Clock"? Did you hit "Save preferences" after updating?

Please take a screenshot of the log after you have hit the Configure command.

I have the same logic on the TH112XZB driver and my 10 thermostats have the clock displayed properly.

Edit : @haganwalker seem to have the same problem with the clock. If anyone using the TH1300 driver would like to share a screenshot of the log, that would help me find the problem.

Also check the value of the State variable hideClock in the driver's page.

Seems like I can't upload screenshots, but here's the log after pressing "Save Preferences", with "Enabling the display of outdoor temperature" at true and "Hide the clock" at false :

dev:302 2020-11-07 19:49:05.291 info refresh()
dev:302 2020-11-07 19:49:05.281 info Sensor type is 10k
dev:302 2020-11-07 19:49:05.279 info Set to Floor mode
dev:302 2020-11-07 19:49:05.276 info Set to 24h
dev:302 2020-11-07 19:49:05.273 info The clock is visible. HideClock = false
dev:302 2020-11-07 19:49:05.271 info Set Clock : Sat Nov 07 19:49:05 EST 2020
dev:302 2020-11-07 19:49:05.249 info configure()
dev:302 2020-11-07 19:49:04.182 info updated() : re-scheduling configure() every 3 hours, and once within a minute.

State Variables :
hideClock : false
scale : C

@Tabrak, your log indicate that the clock should be visible, that's odd!

I had a good look at the Sinope's SmartThing driver and they don't offer an option to display the clock or not and the way they send the time to the thermostat is different. So I did the same as them.

You can try the latest version on GitHub.

@erilaj, the new version now produces the following error :

dev:302 2020-11-09 09:41:08.145 error java.lang.NullPointerException: Cannot get property 'rawOffset' on null object on line 298 (configure)
dev:302 2020-11-09 09:41:08.133 info Sensor type is 10k
dev:302 2020-11-09 09:41:08.131 info Set to Floor mode
dev:302 2020-11-09 09:41:08.129 info Set to 24h
dev:302 2020-11-09 09:41:08.112 info configure()
dev:302 2020-11-09 09:41:07.071 info updated() : re-scheduling configure() every 3 hours, and once within a minute.

Try the latest version.

and now the clock's gone again :

dev:302 2020-11-09 13:07:46.825 info heatingSetpoint: 21.5
dev:302 2020-11-09 13:07:46.660 info heatingSetpoint: 21.5
dev:302 2020-11-09 13:07:46.366 info refresh()
dev:302 2020-11-09 13:07:46.344 info Clock total seconds = 47266
dev:302 2020-11-09 13:07:46.342 info Set Clock : Mon Nov 09 13:07:46 EST 2020
dev:302 2020-11-09 13:07:46.339 info Sensor type is 10k
dev:302 2020-11-09 13:07:46.336 info Set to Floor mode
dev:302 2020-11-09 13:07:46.334 info Set to 24h
dev:302 2020-11-09 13:07:46.306 info configure()
dev:302 2020-11-09 13:07:45.268 info updated() : re-scheduling configure() every 3 hours, and once within a minute.

Anyway to get the light sensor value by any chance ? Maybe we could sync the room light to it ?

1 Like

Hello, @erilaj, @scoulombe, @kris2k2, a really HUGE thank you for all your development and explanations. I have 20 Sinope TH1123ZB. I used SmartThings, but since being forced to use the new App, I wanted to change (too much lags, "offline", no way to set by .5 C) - horrible.
With your great work, I can pilot it better and actually send the outside temperature from my Netatmo outdoor module. Really, really great! Thanks again.

1 Like

I have the sinope hub, but currently looking to change my hub for Hubitat. My older zigbee thermostat from Sinope does not show the word "Out" and my recent one shows it. So, you probably have a version that does not have the capability to show that word.

1 Like

Are they both on the same firmware? This is something that was debated but no one could confirm since no one had the Sinope Hub. Would you mind checking if they are both up to date just in case it's just a firmware version thing?

Not sure if that will answer your question, but both are TH1124ZB with the software version 0.6.4. But the recent one, are material version 2 and the older one material version 1. At least this is the information that I can easily access from my sinope hub in the "info" section on the thermostat.

1 Like

Looks like that answers the question, most likely version 1 hardware will not have the out indicator (probably), thanks for the info!

1 Like

Download the Hubitat app