Simple Automation 1.2

There is a problem with SA 1.2 and set level @ sunset. My 1.1 work but a duplicated 1.2 does not. SA 1.2 that just tasks a switch on @ + or - sunset works fine, but change it to turn on and “set level” and it doesn’t fire.
The devices in question work 100% via dashboard and 100% have and do work via SA 1.1 for many months. RM 5.0 tellig lights to on and set level also work fine. Have nit tried with 5.1 to see if the bug affects it like In SA 1.2

I will look into this. The changes between SAR 1.2 and 1.1 were minimal. But, that should work.

Could you post a screenshot of the rule?

I am not able to reproduce this problem, it works for me. Please show a screenshot of the Event Subscriptions from the App Status page, and turn on logging for this rule.

I recreated the SA rule as a RM and it worked this evening.

I have 2 other lights that aren’t working under SA1.2
Here is the log entry when it tried to set the light last night.

Please show the rule that throws that error.

Those logs you showed are for a device, not for the app. What type of device is it?

A Zwave outlet and Zigbee light. Both work from the dashboard and worked on 128.x

A Z-Wave outlet is not a dimmer, so you can't set the level on it. The app should still turn it on. Which device is 3589 - Guest?

It’s an outlet - dimmer. Using the generic z wave dimmer driver. It’s been working for years as a dimmer. I can operate it via the device or dashboard.

Here is tonight’s attempt for the SA1.2 to activate the lights.

I don't know what to tell you. None of this portion of the app changed. Why don't you make it a Generic Z-Wave Switch (which is actually what it is). It's going to fail when you throw a setLevel at it, because there is no such thing for an outlet. The app thinks its a dimmer, but it isn't. I'm not surprised it's throwing errors. The app doesn't know that it needs an on() command, since it's fooling the app.

Look at its device page, on the right where is shows Current State. What does it show, if anything, for 'level'? Show a screenshot.

Then why does the exact same error occur with the singled Zigbee bulbs. Which are also dimmable, work with every other ( Dashboard, Device, Alexa, RM ) iteration of control but not with SA1.2
Also this device is a dimmer outlet. It’s been in use as a dimmer for multiple years and I can go into the dashboard or the device and dim it to whatever.
I just moved the furniture - here is a picture of said dimmer.

1 Like

Oh, OK. Still show a screenshot of the right side of its device page, and show the Events from the Events button on that page.

I think I've found the problem. For a workaround, put in a value for the fade time where you set up the app , even if it's 0. This is one thing that changed in SAR 1.2. We are investigating if that could be the problem.

Yep, we found the issue. It's an older driver that didn't get updated to accept a null fade value. We will put that fix in. In the meantime, the work-around is to include a fade time.


Here is the device off
Then manually turned on @ 20% via device page
SA1.2 does turn the light off at the specified time


I find it weird that a new RM rule works perfectly, sets level and honors the correct time
SA 1.1 worked fine. Since they were “simple” and I only have 5 SA rules I duplicated all my SA 1.1 rules to 1.2 just to see what SA 1.2 added. Which obviously didn’t prove as simple as I had anticipated.

I will add that to them as the only change and see what happens tomorrow evening .

Fix will be in next release.