Should be able to specify how hubitat refers to itself when handing out links

I have an annoying problem with several integrations. The problem is that when the hub constructs URLs to itself, it will use or even https://HUB_IP_ADDRESS/. The certificate then fails and the clients that are attempting to access the hub don't work. I'm using custom and valid SSL certs. This would be solved if it were possible to specify how the hub should refer to itself instead of using its ip address. This would also allow for more custom setups such as putting the hub behind NAT.

Example integrations where this causes issues are chromecast and sonos.

Here is an example error that I see in the logs:
Error: Certificate for <> doesn't match any of the subject alternative names: [*,]

Is this feature already supported somewhere that I'm not looking? Can anyone think of a workaround?

That would be a function of your HOSTS file that identifies ip addresses to names. Depending on the device, it matters where that file lives. Also, I don't see any way for iOS devices to do this, as they have no HOSTS file available.

No, that's got nothing to do with it.

1 Like

The current work around is simply to use http instead of https. If you want to try and modify what ever integrations you are using, you can try adding the ignoreSSLIssues parameter to all your calls.

Sorry, misunderstood the issue.