Shelly WiFi Plug Not Working R2.3.2

I received 4 new Shelly WiFi Plus US Plugs, I went through the device setup and added the IP address for the system driver. I could not get the driver to talk to the device. I had other shelly devices and the driver usually creates a 0 and 1 channel on the dual devices, yet this one will not setup a channel 0.

I can manage the shelly via web page. This seems to be an issue R2.3.2.134


I think I might be having the same issue. Previous when adding a Plug or shelly switch it would create a Parent and then Child device. Now it does not seem as if the Child device is being created. I even tried to add a previous device that was currently working (had both Parent and Child) and this is doing the same thing. Just the Parent device is created and the Child device (Generic Metering Device) is missing.
Hopefully I am doing something wrong...but I suspect there might have been a change?

any update to this?

Anyone find a solution to this?

I never did get this working. I ended up using the drivers from Shelly for the Plug. One drawback is Google Home does not work.


coreyclerico thank you for the update! I will give this a try tonight!!!

Maybe you can work with @mike.maxwell to see if this is a bug, or something with your particular device.

neonturbo, Would I just email him directly? Not sure the best way to work with Mike not want to be a bother .

I tagged him above, so he should see that message.

Just a FYI I have Shelly 2.5 and the Shelly WiFi driver worked correctly. The issue is with Shelly Plug US which requires the other driver above.

I am still having trouble getting the new plug to work. Wondering if there might be some difference in the new plugs

I never got this working in Hubitat :frowning: I tried installing HA and it picked these new plugs right up :frowning: Not what i was hoping for