Setting Up HousePanel And Linking Accounts

Not sure if this is the correct place but I need some help with the HousePanel App.
It installed fine but now I am presented with the login page and it needs more information to register. Here is where you link a SmartThings or Hubitat hub to HousePanel to gain access to your smart home devices. Like:
API Url:
Client ID:
Client Secret:
Fixed Access Token:
Fixed Endpoint:
Hub Name:

I found the hmoptions.cfg file but it only has this info:
{"config" : {"hubs" : [ ] }, "time": "2.120 @ 15XXXXXXXX"}

I know it needs to know the secret sauce but I am confused on how to get. I am Linux illiterate and a newbie so please be gentle. It took multiple attempts to get this far. :grinning:

You just need the first three. You get these from the HousePanel.groovy app that you have to install from your main Hubitat login page. Typically something like a local URL-

then you have to enable OAUTH2 and then Hubitat will show the client and secret values. The doc at www.housepanel.net explains this part. Ignore the part about Apache. That no longer applies.

Thanks for the info….I found both files and did what you said about the Hubitat side but when I tried to go back to the URL for HousePanel using the same URL I now get a login screen asking for a user name and password not the Housepanel link screen asking for Client secret and ID. This happened once before. The screen has “default” in the User field and password “blank”. Any suggestions?....thank you….

UPDATE-------
I used http://192.168.1.XXX/housepanel/housepanel.php?code=reset to reset and everything works.......now the fun begins....thank you for all the work you have put into the code....much appreciated...

Yea!!! Glad it worked. By the way, I found the bug that makes logins sometimes not work as you experienced. I will post that version later tonight. It has been a big for a long time and I feel terrible that it impacted so many people.

1 Like

Thanks....Do I need to do a total install again or some way of updating my setup? I still keep getting the logon request screen every time I close the browser and it wants a new authorization. Will check later today on Github and see if the update is there

UPDATE:
I tried another browser then it worked....that browser was the one I used initially but when I tried using my tablet I got the Login screen......the working one was Opera and the tablet had Firefox as the browser. Could it be settings in the browser? The tablet is Android and Opera is running on a PC..........

Swapping browsers will help avoid the problem but the real problem was a pretty nasty bug in the code that I think I found and squashed tonight. Please try updating to Version 2.260 that I just posted tonight. If you are happy with your workaround you can stay with it. The update only fixes bugs and doesn't offer any new major functionality.

Thank you....will be waiting for the new version on Github

I found so many problems with the user login. It was pretty bad. ...

So I completely rewrote the login logic. The old logic didn’t work for logging into different panels with different usernames which is silly because that is the whole reason I added logins. Anyway the rewrite does this correctly and it solves all the login headaches people have been experiencing. I found at least three reasons that was happening. Before I post the update I want to spend more time battle testing it.

Stay tuned for the update.
It will be tagged V2.270.

FYI - new version is posted on GitHub

1 Like

Thanks Ken....Will install ASAP. Much appreciated😀

Let me know if you have any troubles. I have a few minor updates but nothing that is important enough for you to worry about for now.

It appears that the update only is for the Linux version not for the RPi 4.....which I am using right now. Is this correct?....if so how can I incorporate the change on my Raspberry Pi?....thanks...

RPI units run Linux so there is no difference. To upgrade the easiest thing to do is to clone the GitHub while you are logged into the rPI. If you did this already for the initial install you just need to log into the PI and do this:

cd hpserver
git pull
npm install
node hpserver.js >& hpserver.log &

if you haven’t yet cloned the folder the instructions are slightly different as:

cd ~
git clone https://github.com/kewashi/hpserver.git
cd hpserver
npm install
node hpserver.js >& hpserver.log &

You may also need to stop the prior app from running first. Try “ps” then kill -9 pid where pid is the number returned by ps

Used your commands and did reboot reloaded HP but the version V2.120 is still on the home page. Is this correct? Did this only modify the code on that version?.....Or should I re-install fresh on the Pi using : ```

cd ~
mkdir hpserver
cd hpserver
npm install hpserver