Set color option not available in RM rule

Hello,
I am new to HE and I would be grateful if anyone can assist me resolving an issue I am having with rule machine event:
I have sengled model: E12-N1E control type: zigbee multicolor, I created a rule for this device however, the set color is not available from all other commands.


I would like to have the bulb change red and green while the garage door is in open state.
Thank you in advance

Oh that's odd! And you've not even chosen which bulb yet so it can't be that it thinks the bulb won't do it! What version do you have on your hub and are you using the latest Rule Machine (not the one called "legacy")

Try setting up (additionally) a Virtual RGBW Light device and see if that adds the options. Maybe the hub thinks you don't have any devices that can do colour, for some reason

Here's mine, this is what you're meant to be offered:

1 Like

Rule machine only offers options that are supported by available devices. If select color is not an available option, that probably means that the driver that was selected for the Sengled bulb is not the right one.

Go to your device screen, select the Sengled bulb and scroll down to driver.

Make sure that the driver selected is the “Sengled Element Color plus”. It probably selected the “Sengled Element plus” driver instead.

2 Likes

Thank you very much for your assistance. I changed the device type in the configuration and the color module popped out. I just migrated from smartthings and need to learn more about hubitat.

Sebastien, Thank you sir. I had it configured it automatically by the system when I paired it for the first time. I changed the type in the configuration and everything is good now. I appreciate your help and your explanation.

2 Likes

That does happen sometimes - it’s a good idea to check after pairing that the selected driver is the right one.

Download the Hubitat app