Sensor issues after updating to 2.3.9

I am experiencing sensors issues with my lights when I upgraded I revert to my previous version and my sensors started back working. Now with the latest upgrade( I lost access with my sensors and lights. I ended up using As of now I can't upgrade my C-8PRO hub. I need to move forward with an upgrade. I am using basic rules.

What's my next move?



This thread is about an issue with basic rules. Are you having an issue with that, or with Zigbee sensors specifically?

1 Like

This is with the basic rule after upgrading to and 147. Sensors not responding after upgrade which cause my lights not turn off after motion is detected.

If you've upgraded to .147 already. Do a reboot with a database repair and then after it's back up open the basic rule then click done and see if that solves your issue.


Are the sensors not working, or is the rule failing?
You would need to turn on logging for the device and the rule and then post the logs when it fails.

Does the state on the motion sensor change to "inactive" or does it get stuck as active?

This is unlikely caused by the update itself, as the update did not include any changes related to sensors. You may want to provide additional details specific to the devices that stopped working, so we can further assist you with troubleshooting the problem.

@rlithgow1 I tried the steps you recommended, sensors and lights worked flawless. I had no issues after your steps. Thanks for the support the issues have been resolved. I am currently on


Glad to hear it!

1 Like

This has really gotten annoying. I disabled and changed all my “wait until” rules 2 weeks ago rather than roll-back, and added additional rules that would work around that. Now with .147 those are broken. I’ll try the reboot….but they really need to address this stuff better.

Have not seen or heard of any other collateral damage from the fix in 147, we would need to see the rules that you think are not working now. Everyone else has reported that the issues were fixed.


I had basic rules that when you walked into a room, it would turn on a light, and then wait X minutes, and turn off the light. Those all broke. So I disabled them, and made it so one rule would turn on the light, and then another rule would turn them off. Now those are broken :frowning_face: I am going to do the reboot suggestion, but may have to recreate the original rules to see if they work. I appreciate the help. It’s frustrating.

If you have a rule that is not working, open it and the click done. Is it now working?