Sengled CT

I have added two Sengled Element Plus bulbs to my HE. I can control on, off, flash, lever but I am unable to change the CT. I have 14 of these bulbs already installed that are working correctly. I have changed to the driver to Sengled Element plus and Advanced Zigbee CT and Generic Zigbee and none will let me change it . I press configure after changing the driver.

There are no errors in the logs.

Also adding these bulbs or changing any of my many sengled bulbs to sengled drivers makes them no longer function.

What's the model number?

They are Z01-A19NAE26

Odd...I presume you've attempted to just pair them again?

Yes, I have deleted and factory reset and repaired to HE a couple times. I even paired them to a sengled hub just to make sure they were not defective. i can fully change the color temp on the sengled hub.

I just paired another one of these Sengled bulbs that has never been paired to a Sengled hub and it works fine. I will return these two problematic bulbs and the Sengled hub that it came with.

Still wondering why Sengled drivers do not work on my hub. Advanced Zigbee CT and Advanced Zigbee RGBW have worked great though.

Personally for bulbs I'm almost all Lifx now (mostly table lamps). Superior color and brightness and 100% local control on hubitat.

But they cost $1,000,000 dollars. :wink:

@user3677 - What driver are you using? I find no problems controlling Sengled bulbs using the Advanced Zigbee RGBW Bulb driver.

1 Like

Mike Myers Evil Laugh GIF

1 Like

14 - Sengled Element Color Plus A19 using Advanced Zigbee RGBW Bulb driver
7 - Sengled Element Color Plus BR30 using Advanced Zigbee RGBW Bulb driver
15 - Sengled Element Plus A19 using Advanced Zigbee CT Bulb driver
6 - Sengled Element Classic A19 using Advanced Zigbee Bulb driver

All the lights above work fine.

Adding two more Sengled Element Plus A19 bulbs that came with a Sengled hub work but color temp cannot be adjusted.

I’m having the exact same problem. I have taken the same steps you have I deleted & re-added the bulb. I changed from the generic driver to the Sengled driver as I couldn’t get the bulb to turn off with the generic driver. When I switch to the Sengled driver I can turn it on and off, but can’t change the CT.

I noticed the details were vastly different between the generic and Sengled drivers
Here’s the generic driver’s details:

And here are the details for the Sengled driver:

Notice the state variables. I have no idea what the state variables are for, but it’s curious that it’s so different.


I’m the logs I’m getting this message when I try to change the CT:

Like the OP I have a heavy investment in my existing stuff, so a recommendation to move to new devices isn’t an option for me (unless someone else wants to pay for it.)

If I understood the logs better and how to debug the system I could probably figure it out, but right now I don’t have time to get that intimate with Hubitat. Maybe in the future.


Dan Q

Weird... and you said you had reset the bulbs and re-joined and no improvement.

Have you tried a FW update on the two bulbs that aren't behaving? Sengled bulbs are supported for Zigbee FW update, from their Device page.

I am not aware that you can update Sengled bulbs through HE. The update button on the device page does nothing. Ill have 4 more new bulbs here tomorrow and will give it a go.

When you click the Firmware Update for a zigbee device (from its own Device page), next go to the Logs page. That'll open to current/live logs, so you can click to Past logs and you should see a yay/nay acknowledgement of the firmware request.

If a f/w update is available, you should then be able to monitor its progress on the current/live logs page -- it may take a few minutes to complete.

Well ok. That worked perfectly for the color bulbs. Nothing for the Element Plus bulbs. I will just swap them tomorrow.

Got the 4 pack of the same Element Plus bulbs today and all 4 paired up and work perfectly including color temperature. Not sure why the two that came with a Sengled Hub would not do color temperature but everything else worked.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.