Send Messages Doesn't Work (Mobile Device Issues)

Maybe it's an Android thing overall. I have a Pixel 6 Pro. If I create a new device using the app, it defaults to the name of "Pixel 6 Pro". The "Device Name" field is not editable.

Back to @Savage:
On the device page for your phone, enter something in the text box.
Click on "Device Notification" (that's a button)

See if you get the notification on your phone.



Okay, I tried it your way, but nothing appeared on my phone, despite everything else working on the app. Weird.

OK, so go do @marktheknife instruction to create a new device for your phone and try it again.

1 Like

Yes, the Android app is different from that perspective. In the iOS app, you can modify the device name, from the mobile app. On Android you have to change it from the hub, then log out and log back in picking the new name. I have a SM- too :slight_smile: That's why I said they are "different".

Yes, but your notifications are working...mine are not. :slightly_frowning_face:

Let me ask this...should I see the messages I am trying to send in the log for the device?

1 Like

Just remove all mobile phone devices from the hub, first, then create a new device. It will be called the same thing again, but once created you can change its name from the hub. If I were to guess, you probably created multiple devices and you are trying to send the notification to a previous iteration. Only the most recent device works. All others are no longer working.

1 Like

Just trying to find within the app how to remove them all...

Go to the hub's interface, click Devices, then remove any and all SM-N986U devices, then go to the app and under Settings select Hub, pick your hub, then select Create New Device on the bottom of the page.

1 Like

Okay, that worked. Thanks!


I just wanted to say thanks to everyone for all your help. I really appreciate it as I am just getting started with Hubitat Elevation.