Select Hub on iPhone not working

Anybody using two or more hubs with an iPhone? I just installed a second Hubitat Hub in a remote location, but when I try to access it with my wife's iPhone, it defaults to the first hub. When I use the Select Hub option under settings, I get an initial message there are multiple hubs, but then it goes to select a device for the first hub. I cannot see a way to get to the second hub. Has anyone found a work around to this?

I have 5 hubs registered to me and don’t recall ever encountering this. Could you include some screenshots?

It would be difficult to include the screen shot in between clicking on Select Hub and getting a list of devices to use to connect to the first hub. There is a brief message that multiple hubs have been found, but I have not read all the message. It stays on the screen for only a couple seconds.

That is very odd - never saw that message…. Maybe try a screen (video) recording, pause it on that screen and take a screenshot of that?

I think I may have found the issue. I see the Hubitat hub dropping off my network on a regular basis. I suspect it was offline when I tried my wife's phone. My router shows it going offline and coming back regularly. I tried replacing the Ethernet cable, but the problem persists. I also switched Ethernet ports on the switch without any luck. The hub is defined with a Static IP Address. There is no conflict with that address. In using the phone app or the web page, I can wake it up for a while, but then it goes back offline. Any thoughts on why it would drop off the network?

I was wrong. The two problems were not related. The hub is no longer dropping off the network, but I cannot pick a hub when logging onto Hubitat or using the Select Hub option in Settings with my wife's iPhone. It automatically selects the first hub, ignoring the second hub I recently installed. I do get a message for a couple seconds that multiple hubs are detected, but then it jumps to select a device for the first hub.

OK, I am getting old. It has been a couple years since I set up my first hub. Turns out I had not added my wife's email as a user on the second hub. Once I did add her, it works fine. I can select either hub. Thank you for all the feedback.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.