Securifi Peanut Plug Power Meter

I have a couple of Peanut Plugs and installed this driver. It works for on/off, but never seems to get any values for any of the power settings. I had a driver installed in my ST days and it was always sketchy as well. I'll keep my eye out for anything I see.

My peanut plugs are up-to-date and with the above driver. It worked perfectly on ST but not on HE. I get this on HE in the log.

warnDID NOT PARSE MESSAGE for description : read attr - raw: 91AD010B040A0505215266, dni: 91AD, endpoint: 01, cluster: 0B04, size: 0A, attrId: 0505, encoding: 21, command: 0A, value: 5266

I updated the penaut plugs using almond router/hub
using generic zigbee outlet driver, it is working so far, but the values are sometimes wrong, like 2588 watts when it's usually around 250. not sure if someone has another code that I could try

did u sort out your peanut problems?

Sorry for the late response. Never got the power reading to work. I just use the plugs for ON/OFF and repeaters.

I have taken the original SmartThings driver written by pakmanwg and ported it to Hubitat.
I modified it to make the power/voltage/current work and allow the setting of reporting criteria.

The code is on GidHub at:

Peanut Plug Driver

It appears to be working on my Hubitat including reporting of power/voltage/current.
The installation instructions are in the readme.
If you have any problems with the driver, please let me know.
Hope folks find this useful.


@jim1 I am assuming that if the current and voltage read 0E-10 that it needs that upgrade you mentioned?

Oops. After posting I realized I'd gotten so busy getting the readme written and uploaded that I'd forgotten to upload the latest PeanutPlug.groovy.
It is now in GitHub. Try it again and see if it doesn't work ok.
Sorry, I didn't expect such quick response.

1 Like

@jim1 Loaded it in and here is a pic.

If you scroll down a bit to Preferences do you see 'Power Change Report Value, Power Reporting Interval, etc.?
If you do, then you have the correct version of the app.
It's curious that I have an entry for energy but you don't. You might try deleting the plug and re-paring it but I don't really expect that to help.
I've never tried using a Peanut Plug with the original firmware so I can't say for sure that this is what is happening but, the consensus from the postings I see is unanimous that old firmware WON'T report power. Even on SmartThings.
Any way you can update the firmware?

I forgot to mention that after you update the app you need to click 'Save Preferences' and probably clicking 'Configure' and 'Refresh' wouldn't hurt either. Otherwise, it might not notice that the app has been changed.

1 Like

@jim1 I have Energy on the right and I have those settings you mentioned in Preferences. There are 6 of them.

Do you have a light or something plugged into it so it draws power?

@jim1 Yes I have one of my cameras plugged into it. The camera uses a wall transformer.

Does it draw more than 2.6 watts? Won't read less than that.

I changed "Power Change Report Value" to 1. But wall transformer reads Input at 120VAC at .2 Amps and output as 5VDC at 1 Amp.

That's 24 watts so it should be showing a value for power and current. Again, though, if you are running old firmware on the plug then it definitely won't report power, etc.
Wouldn't happen to have a Almond Securifi+ laying around the house? Or maybe a friend who does?

No I unfortunately don't have one. I guess I will have to use it as a on/off device which will be OK for the cameras. Thanks for your help. Let me know if a new way comes along to get it to work.

Does you driver do anything to the repeater part of this outlet? Better, no change?

I hear they are excellent repeaters and my driver shouldn't do anything to change that.
Thanks for trying it.

Thanks, @jim1 !

I used your code with only minor modifications, mostly cosmetic.

My Almond 2015 reported values that were different than the driver, but the code seemed correct from my reading of the Zigbee Electrical Measurement Cluster spec.

It turns out the driver is correct and the Almond is wrong, because measurements with a Kill-A-Watt matched the driver.

Thanks for the feedback. If you like, you can do a pull request and I can include your changes.