Seconding the strange HomeKit "no response" that seems to have started again suddenly?

Pretty recent here for me ... things have basically been fine since the early HomeKit integration beta days. Yesterday, my ATV4K updated to 17.4, not sure if that forced the Hub to be one of my HPMs or if that had happened already. Either way, last night/this morning found a specific set of devices to be No Response ... and it dawned on me that they might all be ones that I was exposing through HE's HomeKit integration (I've had Maker API integration for much longer and many of my devices are still using that) ... noticed an update was available, I think I was on .122 and the update was for .133? Ran the update ... still no response on just those devices ... restarted the integration ... still no response on just those devices ... finally decided, ok - the active Hub really shouldn't be the Kitchen HPM, so let's address that ... unplugged it, waited for Hub to switch back to the ATV4K and ... BINGO - devices are all responsive again.

This seems odd, right? This isn't a simple connectivity issue as near as I can parse. Plenty of other bridges were working fine, it was just the HE native HK bridge that wasn't ... I also use Scrypted and Homebridge (Maker API + other plugins) as well as a few native bridges like Caseta. Those were all fine. And nothing about the HPM being the Hub should specifically impact just the HE native bridge, right?

Anyway, thought that might be of interest to @gopher.ny. No "fix" needed, but just wanted to report since things have been really quite stable with the HK integration. This is a C-5, if that's helpful. Maybe something in 17.4 created some instability?

Cheers and thanks for the great product and continuing support and updates!

1 Like

Do you have more than one wireless network? I have found that if I update the firmware on my access points the HomePods will jump to my Starlink network. That's great for uninterrupted service but not so good for automation.

@lairdknox only one WiFi network.

It appears this is happening even when my Hub stays reliably on the ATV4K now, which is unfortunate. It worked for a bit, then stopped working again and I actually can't figure out how to get it working now. I've done a nuclear reset, but I can't add the bridge back after removing it. The C-5 has good connectivity, I can get to the web UI just fine. I'm noticing, though, that it's apparently not advertising on mDNS at all?! Even after I manually restart the integration??

dns-sd -B _hap._tcp doesn't show the Hubitat bridge at all ... HomePods, Wemo Doorbell, Ecobee, Homebridge & child bridges, Scrypted & individually exposed cameras, and any other native HK devices all show up. Using ._udp shows me a couple additional ones. But nowhere is the Hubitat. It should be advertising even before it's added via the QR code, right?

Am having same issue. C7 stays connected, C8 constantly dropping - device shows solid green but cannot get to it via Hubitat app and HomeKit devices all offline. Removing power only way to bring it back. Has to be related to some firmware change.

1 Like

Forgot to add, my Hubitat devices are Ethernet connected

The Homekit integration seems to be the weakest of the built-in apps. When it works, it works but it often just fails and nothing fixes it short of a complete Homekit reset. The lack of logging for the app means it's impossible for us to self-diagnose, or remove a device that could be causing issues.

I've reverted to Homebridge for one of my locations and might do the same for the other one soon. It takes 30-40 minutes to properly set up my Home again (proper rooms & such).

I wish the dev team could help with this since the old "Restart the integration" just doesn't work anymore.

My C7 hub ( is Ethernet connected and so is the computer I am trying to run from (So it's not a Wifi-Assist issue). Homekit integration displays "Active connection: None"

When mine gets in the “no response” state, reboot of HE fixes it. I don’t have to start all over.

Reboots don't fix it for me. Rarely will anything but a complete rebuild of the Home.

The issue I bring up is that we have no way to understand why it's failing. No log, no events, no debugging information.

I'd argue that even if a reboot fixes it for you, it shouldn't fail at all. Homebridge doesn't.

I don’t disagree!
It’s been speculated that some “out of range” or otherwise unacceptable value (from HomeKit’s perspective) sent by HE causes the issue.
I have two hubs feeding HomeKit and I have never seen both of them get in that state at the same time.

I agree that better debugging tools on both ends would help a lot. Anything other than an on/off type device should be able to be logged.
My suspicion is a wild value like a dimmer at 145% or -25% might be the cause.
I suspect neither side does good range checking.

Now my second site's HomeKit integration went down.