Schlage Zwave Plus Lock pairing but not recognized as valid device

I can pair my new Schlage Zwave Plus lock. Hubitat doesn't know what type of device it is and assigns it the device type of "Device". I then go into the lock device settings and change the device type to Generic Zwave Lock. It still does not function. I had an old Zwave model and want to upgrade due to the reporting issues with the old model.

Is the Schlage Zwave Plus lock compatible?

Yes. These schlages are touchy. It didn't pair correctly. Unpair and try again. I held my hub against the lock to pair mine. Took a few trys.

It pairs, but just doesn't know what it is

It has to pair securely or it will not work. This is by (security) design.

Check under Device Details:

You want to make sure you see zwaveSecurePairingComplete: true

I have nothing really listed

You must re pair it, in this particular case maybe you need the hub a little bit near the lock

I've paired it several times with the same result. It also will not exclude and I have to force remove it.

Mine pairs fine, and operates fine under the device page and dashboard, However when setting "to lock" within a given mode change, it almost never fires, yet I go to the dashboard and it immediately locks with manual selection.

Is this with the new Zwave Plus model?

Yes the Schlage Connect zwave plus model

I dunno what it is with Z-Wave+ Locks and HE - it may be that HE is actually doing things correctly in supporting whisper mode etc.. while others are not.

I bailed on the Z-Wave+ module and went with a Zigbee one for my Yale YRD256.

My lock is the z wave non plus version, I had a hard time pairing it but because I paired it in place and hub in place, if I bring the hub to the lock probably will pair faster, but always it got excluded correctly. So, if it did not excluded correctly, what you did to delete HE info on the lock? Did you hard reset the lock? Did you use another device with exclude capability(like aeon remote) to exclude the lock then pair it with HE? Did you reboot the hub to try again?

After the last platform update, it paired (just now) and it recognized more of the attributes. It defaulted to "Device" and I changed it to "Generic ZWave Lock". It worked.

1 Like

I think the lock is new and maybe the fingerprint for it is not available yet on HE, that is why it paired as device but it should work fine with the generic driver. Glad to hear it works.