Schlage z wave lock

I noticed you have lock code encryption turned on. I keep that turned off on mine as I noticed things were a bit flaky when I had it turned on initially. It might be worth a try.

Also - I suggest opening up the hubitat log page in a new tab, and then hitting "Configure" on the lock you are having issues with. You should see the lock fetching all of the codes via the log file. If this isn't happening, then there may be an issue with the Hub communicating with the lock. Rebooting the hub, disconnecting and reconnecting the battery in the lock, and adding repeaters like the Aeotec Z-Wave Repeater specifically, can help.

1 Like

It looks according to your screen shot the State Variable "fetchCode:" Should state 30 along with the "codeFetchComplete" showing "1" like the one I posted....I would agree with @craigspree comment, definitely try configuring the lock again. If it doesn't get all 30 you may have to click the "get codes" and watch the logs until it fully configures all of them.

I turned off the encryption and now see my codes. I don't see a number for the one I created yesterday.

This is the only thing that shows in the log when I hit "Get Codes"

fetchLockCode- 1

starting code fetch, trying to fetch code

Nothing after that.

To me that points to your lock is getting a weak signal for communication (IMO) and would agree with craig again on adding extenders/amplifiers as this is what should happen about every second.

For the time being you should be able to still accomplish this by bringing the hub directly next to the lock and hitting configure, it should automatically get codes but if not you can select get codes. ALSO, a helpful tip would be to "shutdown hub" (not reboot) and when the light turns red pull the power cable for 30 seconds performing a power cycle before doing this (much better success rate with that)

I do have one zwave extender between the lock and the hub. The lock itself is only about 10 feet away. I added the extender about a month or so ago and haven't had any issues till yesterday when adding a new code.

I dont want to side track this lock convo but this is semi relevant. I know with Zigbee I can look at the lqi and RSSI logs to see my signal strengths, is there something similar for z-wave diagnostics? I bought some of those 2 in 1 old iris plugs that act as a zigbee repeater and secondary z-wave repeater and want to make sure they are working properly?

I would try the hub power cycle then, and see if you are able to configure/get codes after it restarts.

Ya I rebooted the Hub a few hours ago. When I get home, I will pull the batteries again and see if I can get codes.

Rebooting doesn't do what I'm referring to with a "shutdown hub", pull the power cord for 30 seconds and restart.

Ok I will kill power when I get home. I"ll keep ya posted on my findings

May/may not work, but here is a post from my previous experience If you completely lose your Zwave radio on your C5 hub

I promise you that we all feel your pain on this. All of us had multiple repeaters, and locks that worked flawlessly on other hubs like Wink before migrating to Hubitat. It caused us a lot of frustration and the only thing that has so far worked semi-reliably was adding a bunch of Aeotec Repeaters. Try to have a minimum of 2 - with one of them as close as possible to your hub, and the other as close as possible to your lock.

Prior to adding repeaters, I had about 15 z-wave plus devices in my small home. All capable of beaming. One of them was 3 feet from my lock. Yet I had super flaky behavior until I got the repeaters. You have a lot of empathy in this thread, I assure you. :slight_smile:

However, now that the HE team has acknowledged there is indeed an issue, a lot of us are very hopeful that we will see a big performance boost with the next major code update (2.1.1) when the Schlage specific driver is released. The HE staff has been pretty great at fixing things and being responsive, they just have a long list of things they are trying to work on and they are still a small and growing company. I am willing to be patient with them as the Aeotec repeaters make my locks work 95% of the time, and I am confident that the HE team will take care of us as soon as they can. :slight_smile:

1 Like

Ya know. I have to check and make sure my Aeotec is still plugged in. My wife was out in that room and I wonder if just if she may have unplugged it. Again I will try the following.

  1. Make sure Repeater is still plugged in
  2. Shut down hub
  3. Unplug for 30 seconds
  4. Restart hub.

Okay I shut down the hub for a little over thirty seconds, disconnected the battery at the Lock, restarted The hub, reconnected the batteries at the Lock, logged in did a get codes and it got all the codes. the one code that I have been trying to delete is now gone. I am now able to lock and unlock the lock from the device and dashboard. Thanks a lot guys I appreciate the input and figuring out how to get this thing back. As of right now the lock is working properly.


Well I spoke to soon. It not working again

I would think if your lock is that close with an extender you "should" be fine, but with my 3 locks things didn't completely iron out until extender #4 with the problems improving after each one added......Are you using the Reliable Locks may help, as it polls the lock routinely.? FYI also if you just recently added that extender it may take a day or so for your mesh to completely settle down.

[Release] Reliable Locks

1 Like

I have installed the reliable locks app. We will see how that goes

So how did that go? Experiencing some of the same issues...

Everything has been working great.

1 Like