Schlage FE599 Lock Ignoring Keypad Events

Using the Generic Z-Wave driver, the Schlage FE599 lock is not registering keypad PIN events. (i.e. unlock)
This means the lock never reports that it was unlocked from the keypad, or by whom.

Enabling debug mode, I can see where the driver is ignoring the event.

[dev:361]( 11:25:18.651 am [warn]( zAlarmType:0, zAlarmEvent:0, alarmType:16]

[dev:361]( 11:25:18.650 am [debug]( AlarmReport(alarmLevel:1, alarmType:16, eventParameter:[], numberOfEventParameters:0, zensorNetSourceNodeId:0, zwaveAlarmEvent:0, zwaveAlarmStatus:0, zwaveAlarmType:0)

dev:3612018-12-27 11:25:18.646 am debugparse: zw device: 4C, command: 9881, payload: 00 71 05 10 01

This functionality was present in SmartThings so I ported over the SmartThings lock driver and it works now. The drawback is that there are architectural changes in hubitats lock code management so those features do not work.

It would be great if support for this alarmReport were added to the stock driver as the lock otherwise works fine.

Edit: Even with the modified ST driver, it seems that Lock Code Manager is still not logging the usage of the code slots.

dev:4412018-12-27 11:38:20.772 am info[DTH] parse() - returning result=[[name:lock, value:unlocked, isStateChange:true, descriptionText:Unlocked by "{code=????, name=Steve}", data:[codeId:1, usedCode:1, codeName:{code=????, name=Steve}, method:keypad, lockName:Lock, Side Entrance]]]

I have 3 of these locks so it would be nice to get the functionality on par with ST.

@mike.maxwell, is this anything you can look into?

I believe this has been submitted as a feature request. I could be mistaken, but knowing which code is unlocking the door has been a topic as of late.

Thanks April! It seems to be a sizeable omission but I know there are a lot of different lock flavors out there. I wish I had caught that limitation before beginning my move away from SmartThings. I would have waited for the fix.

I use the system in a duplex which I own. Locks and code management are a top concern. I can use my patches driver so long as I don’t need to change or add codes so I can get by for now.

You could always change your post to a feature request. Then the developer of lock manager will see it and respond on status. Just a suggestion.

This has been available for a while now. I get alerts with who opened my front door daily. This is more likely an issue with that particular device. I use the BE469.

It has to be, since the logs indicate that the default driver is ignoring the alarmReport event. The driver needs to be updated to include that event type.

An update to the built in driver will be in release 2.0.4

Schlage locks do not return any of the configured pin codes stored on the locks, when the driver sees this it returns ???? for the pin code.
Any existing codes on these locks will first need to be deleted, then added back in via the driver or LCM, after this is completed the pin codes will be shown in the driver and LCM

1 Like

can you post me the fingerprint for this lock?, its located in the data section of the driver details, thanks.

Will that be true in 2.0.4, because it is not today. When I paired the 3 FE599s I deleted all of the stock codes before setting codes with LCM. I still see ???? for all codes and it appears that LCM has “forked” those code assignments. When adding a new FE599 lock for a user, I have to add them to the lock showing the pin, but after adding it appears in the second group.

Here you go...

  • deviceType: 25419
  • zwaveSecurePairingComplete: true
  • inClusters: 0x85,0x73,0x72,0x98
  • deviceId: 20556
  • MSR: 003B-634B-504C
  • manufacturer: Schlage

Will 2.0.4 have a fix for the BE469 locks?

Not following this exactly, lets leave LCM out of it for the moment.

If you go to our driver and enter a new pin code, does the code add and then display in the driver current states: lockCodes?

Unknown, we are including some changes to Z-Wave secure initialization, which may help.

Negative... I just added a code to slot 6 from the driver and it’s showing ???? for the code. The code does work however.

I’ve redacted names other than my own.

Current States

  • battery : 73
  • codeChanged : added
  • codeLength : 4
  • lock : unlocked
  • lockCodes : {"1":{"name":"Steve","code":"????"},"2":{"name":"user1","code":"????"},"3":{"name":"user2 (tenant)","code":"????"},"4":{"name":"user3 (tenant)","code":"????"},"5":{"name":"user4 (tenant)","code":"????"},"6":{"name":"Test","code":"????"}}
  • maxCodes : 19

I’m willing to test anything in advance to see if it helps. I have 4 of these locks. 2 connected 2 do not. Those remain on SmartThings for now.

OK, we'll have to see, but the update that will be in platform 2.0.4 "should" resolve this issue as well...

I'm having a similar problem. I'm using the default z-wave driver. And it sees nothing when the it is locked or unlocked directly on the device (keypad outside, or simple lock/unlock inside).

I'm able to refresh and see the current status of the lock. I'm able to lock and unlock from the device page.

But I don't see any activity in the logs when I lock or unlock (from the physical device or from the device page in the Hub). I also don't see any of that activity in the Events section under the device. The only thing that does show up is when I click on Refresh. And that only shows up under the device event history (not the logs).

Clearly, it's not set up right. Is there another driver I should be using? I know all of this worked really well on Iris. In the current state, there's no way to trigger alerts, which is one of the most critical factors of home automation for us.

Any thoughts/hints/tips would be welcomed.

The Generic ZWave Lock is the correct driver.

You should see something like this (snip) in the logs when you unlock it with a code on the lock keypad.

I believe for that to work, I have to have put that user's code into the lock using the Lock Code Manager (not manually through the lock keypad). I'm not 100% sure that's a requirement but that's what I did.

Here's what mine looks like. But I only get any Events when I hit the refresh button on the device page. Otherwise, nothing shows up here at all.

That is indeed odd. I've got nothing for you. Hopefully the Hubitat Team can assist you.