Schlage BE468 Lock Dead - Not a Hubitat Issue

One of my Schlage BE468 locks seems to have died. I put fresh batteries in and no lights on the keypad, the Schlage button on the interior side of the lock doesn't light up at all or beep when pressed.

Seems power from the batteries isn't getting to the device. I put a volt meter on the battery pack and power is leaving the battery pack.

Has anyone had a similar issue and fixed it? Not a big deal as this lock was replaced by Schlage under warranty for a different issue but would be nice to be able to fix it if not too difficult.


Is it possible that the keypad has become unplugged from the lock electronics, or that the keypad plug isn’t seated well? That would cause the symptoms you report..

Bad solder joints too. That lead-free solder is just awful for cold solder joints and for growing whiskers.

Could the lock have a lifetime warranty? Some do... Might be worth checking...

1 Like

try doing a Schlage lock reset.
With the battery pack unplugged on the outside of the lock while pressing the Schlage symbol wait 10 seconds and plug the battery pack back in (while still pressing the Schlage symbol).

1 Like

I had a the same issue with a replacement lock that Schalge sent me. My first lock was problematic as soon as I got it. I called Schlage and they replaced it and told me to keep the original and not send it back. The replacement lasted about a year and then the keypad went dead, as you described.

I called them again and they sent me another lock, again telling me not to return the old.

The first lock, which I still had, would lose it's codes but the key pad seemed fine. After installing the latest replacement I decided to see if I could put the two locks together and it worked. I got a second lock out of the deal. Both of these have been working now for a number of years.

Check around maybe you can find someone with an old lock. It seems to be common practice for Schlage to not request failed equipment back, there may be some cheap replacement parts out there.

1 Like

Thanks for your reply. I did check that and it's securely plugged in.

I think this is the most likely explanation. Do you think a bad solder point would be easy to find ?

I did try this but it seems completely unresponsive. No lights or sounds at all. I don't think I waited 10 seconds so I'll try that just for good measure if that's an important step.

Luckily this lock was one that was warrantied with a new lock so I'm not out anything. Just used this lock on a not commonly used door. The keypad would go dead but disconnecting the batteries would solve the problem so it was still usable in this case.

1 Like

Sometimes they are obvious, and sometimes not. I have repaired many automotive instrument clusters, and often what I end up doing is reflowing all solder joints because you cannot find the one bad one.

At the very least I would take a magnifying glass and carefully inspect everything. You might get lucky and see a defect.