Scenes aren't available to all Google home members

Hi all,

I'm trying to setup my wife's Google home account to enable night mode by enabling the night "scene" in Google home when she says "goodnight".

This works fine on my phone likely because I've added Google hubitat as a service in my Google home account. All the devices are then shared with my wife through Google home since she is a member of the home. It seems that scenes aren't shared with her though as the scenes option is greyed out in her routines section of Google home.

She has her own hubitat account so perhaps adding hubitat as a service under her own Google home account would fix this but I'm nervous that doing this will duplicate our many devices in Google home.

Is this a bug with hubitat that she, as a member of our Google home, can't see scenes I've shared with Google home but can see every other device?

What do you mean by "scenes"? Do you mean Google Assistant Routines? Hubitat Scenes should show up in Google Home as switches. If you are talking about Google Assistant Routines, then no, those are not shared when you share other devices. Those are unique per user.

Yes correct, the scenes show up on my account as switches. It seems virtual switches don't show up on my wife's Google home account either. I thought I could work around this by creating a virtual switch that her Google home would see and turn on night mode as part of her goodnight routine but that doesn't work either. Any thoughts how my wife's Google home account can put the hub into night mode? have to run this by me again. If you have added the switches your home and your home is shared with her, she should be able to see them. Are you sure they are added to your home in Google Home correctly?

Yup! All devices show up except for all my virtual switches and scenes even though they are shared in the Google home integration.

Edit: and the night mode doesn't show up.

Here's what shows up in my Google home:

And here's what shows up on my wife's Google home account:

Actually seems like devices that aren't assigned to a room on my account, aren't showing up on my wife's account.

Ah ha! That was it. If the device isn't assigned to a room by me, then it doesn't show up for my wife. I added the virtual swtich to a room and it instantly showed up on my wife's Google home account!

Although I'm not sure then how I would ever get the Hubitat modes to show up on my wife's Google home...


I don't believe they do. You would have to set up a virtual switch and then assign those to a room. Little tip, a "room" doesn't have to be a room. For example, I have one that is "Whole House" for stuff like the thermostat and modes. I also have one called "Blinds" since they show up in GH as lights but aren't really lights. Segregating them to their own room prevents them from changing when i 'Turn off the kitchen lights' for example.

1 Like

Odd that you can choose what modes to share with Google home but they don't show up there

Thanks for the tip about the rooms. That is probably why when I say to turn on the living room lights, it also turns on the Fan of the child device of my Hampton Bay wink controlled!

1 Like

Yup...that's why. I also have a room called "fans". :slight_smile:

1 Like

Thank you!
I had created multiple virtual switches in Hubitat to control automations in Home Assistant. I set up "routines" in Google Home to toggle the virtual switches with voice commands. They worked great for me but when my wife tried, all she got was "Hoobitat doesn't seem to be available right now" (we use the English accent on Google and she pronounces Hubitat funny)
After I assigned the virtual switches to a room in Google Home, everything worked for her!
Thanks again!