Scenes- All Lutron devices go to 100% in 2.3

Hello,

I updated to 2.3 and now all my scenes playback at 100% intensity with my Lutron Caseta devices. Not sure why this is, but came home to the house lit up very bright. I have rebooted the Lutron hub for good measure. Logs indicate it comes on, goes to the correct level, then shoots up to 100% registering as a physical push.

Anyone else? I rolled back to 2.29 and everything is running fine.

I believe there was a change made with how "On" works in 2.3.0. What do the settings on the device page for the device(s) in question look like, and what app is sending these commands to the device?

The scenes app tells them when to turn on or off and at what level. The setting on the device page for the Lutron devices aren't very many. The only one I can see is "use last level for on". Still, unchecking that or checking it seems to make no difference. In each case, the level jumps from the set level the scene gives it, to 100%. It appears to be specific to scenes, Lutron devices on motion app recall levels just fine. I am back on 2.2.9 for the moment.

On the Lutron dimmer device page, there is an option for on to take the last level value. You should turn that option on. This will resolve your issue.

@bravenel

You are talking about each individual Lutron device, right? The setting "use last level for on"? These were selected in 2.2.9 and were also selected in 2.3.0 before I rolled it back to get everything dimming right again. I can roll back up to 2.3 and try toggling the setting off/on again, but this was selected and the problem persisted. With each scene I tried in 2.3, the level would correctly set as a digital interaction, and then within a few milliseconds, jump to 100% and register as a physical interaction.

There was a change in Scene in 2.3.0. In 2.2.9, this setting didn't matter. It does matter in 2.3.0.

@bravenel did roll back up to 2.3 and ran a bunch of scenes and also ran a bunch of my routines. The problem seemed to occur as described. I went into each Lutron dimmer device and confirmed the toggle for that setting was on. I went to each device and toggled off and on that setting once or twice, now it appears to be behaving. I will put it through its paces for a couple of days and report back. As always, thank you for your quick help.

After changing a preference for a device, you have to hit Save Preferences for ti to be saved.

So is it normal for the state variable "last level" within the Lutron device to only update when the command to change its intensity is issued from the hub? I am noticing that setting the level from the device page or via a digital command updates the last level. However, when I change the state physically at the dimmer, the current state level updates, but the last level does not.

The behavior when you hit the physical dimmer depends on how you have the Lutron system setup. As for the state variable in the driver, you are right that changing the physical dimmer would not affect that. So you are correct that the last level is set by the hub adjusting the level, not the physical switch doing so.

The change in 2.3.0 was to the Scene app. Previously, it would issue a setLevel command, which will turn on lights to the selected level. In 2.3.0 there was a change so that it also sends an on command after the setLevel. For a Lutron device, on() usually means go to 100%. This the behavior you reported. What the preference on the device page does is capture the level sent by the setLevel from Scene, and then apply that level to the immediately following on command. In theory, that means that the lights turn on to the level, and don't go to 100. Others have reported that this fixed the issue they had at first with Scene activation causing Lutron lights to go on to 100.

1 Like

Understood! Is there any chance we might ever see or can get last level pre-staging on these devices? I fade them to 1% then off when I go to bed. Another command to pre-stage them back to a level so I don't get 1% when I call on them through Alexa the next day might be nice.

I am seeing the behavior with my roller shades scene.
Using Fibaro for-223 to control the shades.
I capture the shades position in a scene.
But when I activate the scene, it looks like Hubitat ignores the required position and just turn them all the way up.

I ended up deleting the scene and not using it. Used RM to set the shades to the required position (each one to the desired value) . This is a work around but it works.

Does the blinds device page have a toggle for a “use last for on”?

I got this state variable to correctly populate once, it seems to be working right again today for the most part. Like mentioned, the intensity, or i am assuming in your case position, is put there by the scene before being recalling by the scene when “on” happens.

We're caught between two conflicting issues with this change to Scene. I think we need to introduce this as a settable option in Scene, whether or not to use a discrete on command when activating a Scene, with the default to off for that option (behavior prior to 2.3.0).

That will fix this for you for blinds.

5 Likes

Can I ask what the conflicting issues were that drove this change? Curious for understanding sake.

Some people have devices that wouldn't turn on without an explicit on command. The way it worked before, and again will, is that it checks to see about setting color temperature or color or dimmer level -- any one of which should turn on the lights. Only if none of those were needed would it turn on the lights with an on command. In the change, an explicit on command happens after all of those. The option will default back to the way it was, and allow the new way for those who need it.

7 Likes

I am having the same issue with dimmer going to 100% regardless of dimmer value when using scenes despite "Use last level for on enabled". Not sure what to do next. Thanks

New version of Scene coming in next release. Will fix this.

2 Likes

Are you using Lutron Dimmers? If so, set the “Use last level for on” to disabled, and click Save. Then set it to enabled, and click save. This resolved the issue for my Lutron dimmers.

2 Likes

Download the Hubitat app