Scene invoked from rule-machine trigger by mode change doesn't set devices

I have been using rule machine to activate scenes for a while now, and generally it works fine. Now that I am getting more comfortable with the c7, I am trying advanced configurations. What I have done is instead of triggering my rules based on time of day, I have them now triggering based on mode...and of course the modes are set by time of day.

What is happening now is that the mode is getting set when it is supposed to. The rule trigger is fired and invokes the scene. But the scene doesn't set the devices. Some scenes set some devices but not all...other scenes set no devices. I see all of this in the log. This seems like a bug to me, because I can invoke the scene successfully in the console, or by using Google Assistant, and like I said, it used to work when invoked by Certain Time triggers in rule manager.

Here is an example.
image



Notice how after Dawn was turned on, there are no devices that get turned off as my scene is configured.

Obvious thing to do is turn on logging in the Scene. See if it's sending the commands or not that way.

I actually changed my process a little bit. I removed the scene called Dawn that turned all the lights and switches off and instead turned off the Bedtime scene which originally turned the lights and switches all on. After logging that this morning, it looks like the scene issued the commands, but the lights were all still on.

image

image

image

Again, I told Google Assistant to turn Bedtime off, and all the lights and switched actually turned off.

What kind of devices are these?

Do you have On/Off optimization turned on for the Scene? If so, turn it off!

Combination...There are 2 Z-wave light bulbs (Coach Lights), some dimmers, and some switches.

I already thought of turning off optimization...so that's off.

I just re-created the Bedtime scene and the rule that turns it off and enabled logging again. Will see if that did anything tomorrow. The scene turns on fine based on the Evening mode which I have set to switch to at 10:30pm.

@bravenel Well that didn't work. Woke up this morning and the devices were still on even though Hubitat reports in the logs that it issued off commands. Any other ideas?

image

I just ran a test. I enabled logging and simply ran the actions from this rule...

image

And the log shows the same thing as I just posted above...but here it is with this run...

image

And the devices are still on.

Again, I can just manually push the Off command on the Bedtime scene device, or ask Google Assistant to turn it off, and the devices turn off.

It looks like there is a disconnect when the rule engine invokes the off command.

I just created a simple automation rule and it is worse than the rule machine. This one doesn't even issue the device off commands.

This is the only thing that's logged.

image

Are these all Z-Wave devices? If so, check Settings > Z-Wave Details to see if you have Firmware Update button towards the top, as shown here: Z-Wave Details - Hubitat Documentation (note that this is not the Update button in the top right). If so, I'd highly recommend running that update, which most users have found to improve their Z-Wave experience, especially when dealing with occasionally-unresponsive devices, as it seems you might be. (I suspect that it's just coincidence, so far, that it seems to work when done manually but not via the rule's scheduled execution--either would probably fail or work at "random" if tried enough times. The rule is, perhaps, more likely to fail if you're also controlling other Z-Wave devices at the same time, at least if you hit the bug this fixes.)

If you don't see that button, that's OK -- either you're already up-to-date, or you're not running a C-7 hub (the current model and the only one this applies to). Enabling metering in the scene may help if you haven't tried that already and still experience problems.

Your logs look the same in both cases to me: the app says it's sending an "off." The device generally won't log an "off" unless the state actually changed--that's an "info" or event "descriptionText" log (which genereally just show these state changes...though this may be different for scene devices; I'm not sure how that was implemented), not a debug log that shows if/when the command was called (which only some drivers do but even then only with debug logging is enabled).

In almost all cases, this is a device or mesh issue, not an app issue, and all evidence I see still suggests that this is true for your case, too. Hopefully the above will help you figure something out.

Yes, they are all Z-Wave devices. I don't have a Z-Wave firmware update...I did the most recent update a week or so ago. And I do have a C-7. Also, my C-7 firmware is up to date too.

What I am experiencing is not random at all...it's consistent. I can consistently turn off all of the devices with a manual off command to the scene directly, but through the rule machine or simple rules engine, it doesn't turn the scene nor a single device off.

As in my original post, the way I used to do this was I had a scene called Dawn that explicitly turned off all these devices and had a rule that called that scene at sunrise. This worked consistently. Then I changed to activate Dawn when the mode changes in the rule machine and it wouldn't turn off the devices. Then I changed to turn off Bedtime (which is the mode that turns all of the device on that I want to turn off in the morning) and it also wouldn't turn off the devices. All of these configurations should work right? Perhaps I should just go back to the old way of doing it, because this just isn't working.

Download the Hubitat app