Scene control

Good morning. Connecting up a new system for my brother and not near my hub to check the rules I had set up in the past. I’m trying to use a GE Embrighten switch to set up a scene control where a double tap on the GE in his house will turn on a smart switch connected to his pool lights.
I know I’ve done this in the past but seems like the rule machine app has changed since doing that.
Looking for the best ( or simplest app ) to get that automation. The other problem I’m having is that even though the GE switch is listed as a scene controller when I look at the logs, a single or double tap lists the same button. When I single tap up the house light comes on, if I double tap the house light still comes on. For some reason ( on my hub) I seem to recall that a double tap will give me a different button pressed and doesn’t activate the light that the switch is connected to. One more day here and would love to get that working for him before I leave. Appreciate any thoughts.
Thanks.
Mac

First thing I would try is changing the driver. If you are using the hubitat driver, I would change over to one of the community drivers and see if it recognizes the double-tap better.

If that doesn’t work, another option might be to use an Inovelli switch instead - they will be back in stock shortly, if they aren’t already (Inovelli.com). Their scene control works extremely well. Their config button could also be used for this, making it much more intuitive.

Finally, I would likely use either a Basic Rule for this or the Button Controller app. Looks like there isn’t sufficient complexity to require the use of Rule Machine.

Will update the driver and reply back. Sadly waiting for an Inovelli won’t work. Only here one more day!
TIA.
Mac

1 Like

Are you positive that the GE/Jasco device supports this, and that if the GE devices do support it now that you are using the right model to do that. I had a few GE Zwave Plus switches and they didn't support this function. I had to get Zooz Switches to get the Scene controller options. They were fairly rock solid but limited on capabilities.

1 Like

Well. I’m clearly doing something wrong.
I updated the GE driver to the user developed one. A double tap up logs button 3. A double tap down logs button 4. ( didn’t do that with the OEM driver ).
I used rule machine and created 2 different rules.
Trigger. Double tap up (button 3 )
Action. Kitchen lights on

2nd rule.
trigger. Double tap down ( button 4)
Action. Kitchen lights off

Nada. Yet when I run the rule from within rule machine it will operate the kitchen lights.

Not being sure if this was a GE scene controller issue. I tried using another switch as the trigger. A zen 76 which states it is a scene controller. For some reason I don’t see a difference in the logs between a single tap or double tap.

Not sure if this makes a difference but the switch I’m using as a trigger is on a different hub than the switch with the lights in trying to control. They are linked together with him mesh however. I can operate either from the devices page on the opposite hub.

Appreciate any thoughts.
Thanks.
Mac.




Make sure you clicked on done all the way through. Click on the gear next to the rule and make sure it shows it is subscribed to the button press as well.