Run Rule option gone?

I remember from several versions back an option to run a rule so to test the actions. I don't see it now, have I gone blind, or just senile?

Thanks

In rule machine it's run actions on the home page of the rule. It's still there for me.

3 Likes

It appears only after you save a rule for the first time.

7 Likes

Hi!
Its also on my rule page, when I open it after it is created.
+1 for @april.brandt’s experience.

3 Likes

Hmm. Looking at some "Triggered" rules the Run Actions is there, but if the Rule isn't triggered then it is absent.

Hmm...
This rule is triggered now, and it’s still there:

Could it be when the rule has a counter/delay action in progress this happens?
On firmware 2.1.9.114 on the HE here.

What version of rules are you looking at. I have a few rules that I run from other rules and I do not fill in any triggering.

3 Likes

Can you post an example of the rule you experience this, please?

3 Likes

This is a Rule 3.0 rule. I'm not sure "Run Actions" was available in Rule 3.0. You could consider re-creating your rule in RM 4.0.

3 Likes

I thought of doing that.

2 Likes

Actually it is on RM 2.05 So most likely that is the issue and I never realized it.

2 Likes

Ahaa!
Finally some logic!
This one had me go crazy, almost.. :sweat_smile: :crazy_face:
I’m on RM 4... :wink:

Yeah I am up to date as well. Is there a method to "upgrade" existing older rules to the current version? Something where I don't have to remember how I did it in the first place? :))

Nothing is available to convert the old rules but I'm sure if you post a screenshot of your old 2.5 rule there will be a few responses with a current representation.