Rules not firing randomly

I have had this issue for some time, but it seems to be becoming more frequent now. Some of my rules stop working randomly, including Basic rules, RM (Legacy) & Simple Automation rules. At the same time, other rules within those apps keep on working. Here is one example of randomness, but I can share more from other apps with similar behavior (or where it didn't fire at all). And yes, it has been colder than 72 in this case and thus I expected it to fire everyday. I am on C7.

Someday it fired and on others it didn't !!

I would try turning off optimisation first.
It could be that the rule/HE thought the switch was already on and therefore did not send the command.
Just something to try.

1 Like

Are z-wave or zigbee devices affected more? Or both pretty evenly?

These are all zwave devices. Zig bee is stable.

Given this, have you examined your ZWave Details for ghosts or incomplete pairings?

2 Likes

Exactly where I was heading (as always)

@yashvind can you post a screen shot of your z-wave details page?

1 Like

I don't see conclusivve evidence for this. What you'd need is a lack of log entries for then app at the expected time (which you should have since I see you have logging enabled in the app). What appears to be a rule problem is often just a device not responding as you expect, and the event history you did show for the device tells you what the device reports back to the hub, often in response to a command, but not what commands were actually sent.

You've got some good advice above that should help you get started figuring that part out. Just wanted to add a little in about troubleshooting in general. Good luck!

Here we go below (I had to redact a few of the names for privacy reasons if you see some device names blurred out). I see a couple of orphan nodes - Wink hub died, it seems, and one of the shade remotes is also MIA physically, so I can't exclude either. I tried to run a repair on both, hoping it would give me a 'remove' button (this approach has worked for me past), but I didn't get the remove option. I guess the next step for me is to force remove it from the device page & wait for it to get removed from Z-Wave Radio after some time?

Your mesh seems a bit weak in places, especially 0x02 (the motor). You could probably benefit from some beaming repeaters... (I reccomend Ring v2's) Even though you have a lot of mains powered stuff, if they're in metal boxes signal can be hampered (as well as plumbing and electrical in the wall)

I had a similar issue, old SA rule been running for ages just stopped, could manually control the device. Turned logging on and nothing from the rule.

Took a backup and did a soft reset, reinstalled the backup and its working fine.

No reason to become corrupt as hub on power supply buy might be worth a try.

Probably could have deleted it and recreated it...

I have 2 aeotec repeaters configured, I will try to see if I can/should reposition them because it's been a while since I added those and other device placements have changed a bit since then.

1 Like

If I am reading this correctly, your rule is triggered on temperature events between 5am and 8am, so look into the events for the temp sensor.
How often is it reporting? What is it reporting and when?

Download the Hubitat app