Rules all died!?

I've got a C-5 with 2.3.0.124 currently running. Device has been around for well over a year.

Suddenly, all my rules seem to have stopped working. They're a mix of Simple Automation Rules v 1.1, and 1.2.

I checked the devices manually and for example when a motion sensor goes off, it does detect it as active... sometimes I see a rule firing in the logs, sometimes I don't.

I also can't manually take actions - for example my zwave light, if I try to manually press "on", nothing happens. Mix of z-wave and WiFi appliances (i.e.; Hue)

I tried a z-wave repair and didn't see anything noted.

Any clues!? I'm completely stuck!!

Thanks

Try simply shutting down the hub via the Settings menu. Then unplug the power supply from the wall (not the hub, as the microUSB connector on the motherboard doesn’t handle repeated stress too well.). Wait a few minutes and then plug the power supply back in.

The reason for the full power down is that it gives the Z-wave radio a chance to fully reboot.

5 Likes

No change :frowning:

Contact Support and have them take a look at your hub.

1 Like

Emailed them last night. Haven’t heard back yet. What’s typical response time?

Did you receive a ticket number?

1 Like

yes

From what I see, 24 hours or less most of the time. But with the holidays, and the influx of new users, I bet they are closer to 48 hours for the next week or two.

If you didn't get a support ticket number, it didn't go through.

1 Like

OK thanks - i'll sit tight!

You could try backing up your hub to your pc so you have a current file with you hubs data.

Then do a soft reset at :8081 followed by a restore of the backup you just made.

I don't think this would hurt anything and might get you back up and running.

3 Likes

Should I try to downgrade to a prior working version?
(Side note; never done a restore before... that won't impact my z-wave devices and such, right?)

it will not affect your pairings.. the Z-Wave data is stored on the ZW chipset.

Here is the soft reset info:
https://docs.hubitat.com/index.php?title=Soft_Reset

2 Likes

Soft reset staying on same version worked!!!!!

THANK YOU!!!!
(now i'd love to know what the heck happened and why!)

3 Likes

Likely your hub got corrupted by something - power failure maybe? Is it on a UPS?

2 Likes

Glad I could be of help - more glad that you're up and running again.

2 Likes

Yep, the same happened on my C5 with that update but not on the C7. Couldn't control anything from the app and some rules worked and some did not. Half of my Aqara motion sensors worked perfectly....
So i did a soft reset but i had to reconnect many sensors and some of the Ikea bulbs anyway,

Download the Hubitat app