Rule won't set more than one scheduler Eco Mode

,

Running version 2.3.4.115

I've got a rule that is intended to set all my thermostat schedulers to Eco Mode. I can see in the log that the rule run but not all schedulers will turn Eco Mode ON/OFF. I can reproduce the same behavior just by pressing run actions in the rule.

Schedulers before:

Schedulers before

The rule actions, select by App Name (one action for each scheduler):

I click on Run Actions and after, only the last scheduler is activated:

Scheduler After

Let's try something else! This time select by thermostat and select all (all scheduler at once):

Run Action and then, still only one scheduler activated, but this time it is the first one:

SameButFirst

Anybody has an idea what's wrong?

I can confirm this behavior. Will get it sorted out.

Bug found, and will be fixed in the next release.

2 Likes

Thanks for the fast response! :+1:t2:

I confirm, problem solved with 2.3.4.117.

1 Like

Hi @bravenel , I found out there is still a bug when setting more than one scheduler, when using Select by thermostat.

Here I create a rule with only one action to set all my schedulers to Eco.

I selected all available thermostats

The result is only one scheduler gets activated
Only one set

To workaround, it still works to create multiple actions, one by scheduler, with Select by App Name

Thanks for you help, I wish you happy holydays.

EDIT: I'm currently at version 2.3.4.123

Yeah, that never did get fixed.

1 Like

Download the Hubitat app