Rule with required expression not running

I have set up a rule to only run between two times, but the rule is not getting kicked off during that time. I need some guidance as to what I am doing wrong

I would recommend that you change the Required Expression to “… Sunset-31 minutes …”. Otherwise, your trigger will not work as it would run while the rule is halted…

If this doesn’t work, you can turn on logging and post your logs. Does turning on the switch work?

You should be able to set the trigger for the ZZZSwitch to turn “on”, as nothing will happen when it is set to off from what I can see…

I had tried setting the trigger to Sunset-29 and that didn’t work

I changed the required expression to sunset-31 and that didn’t work either

Turning on the switch when the required expression is true also did not work

I am seeing this in the logs for this rule

If you turn off the required expression, does the rule run? Would you post a screenshot of all the relevant logs for this rule?

Since the rule doesn't do any thing when the ZZZSwitch is off (ok, it runs a 5 second delay), why not just make the ZZZSwitch trigger turns on?

I changed the trigger to switch on and that didn’t get the rule to run either

Yes the rule runs fine without the required expression

@mraz.camren Make the required expression between two times that will allow it to run now. Turn on logging then post the logs.

Yeah the rule is not running. This is only error I see relates to this rule

@mraz.camren Since you haven't posted logs of the rule, it's not clear to me the you have logging of the rule enabled. Would you confirm that you have Events, Triggers, and/or Actions enable then post the logs?

Yes I have all three enabled and the screenshot I posted above is what I see in the logs regarding this rule. Am I supposed to check rule logs elsewhere?

Here's an example of my logs. I don't see a time stamp with your logs so that looks odd to me.


I'm not sure what the error that you posted means. The rule looks simple enough. If you recreate it, do you still get the error?

1 Like

Recreating the rule fixed the issue. Thank you

Download the Hubitat app