Rule Shows Repeating but nothing should be

I have a rule to turn my holiday lights on/off. I have repeats in there because sometimes it seems like the off messages don't arrive and lights are left on all night. The current time is 6:58PM on 12/29/19. As a result this means I'm in the ELSE IF that is for the Dec1-Jan10, and I should actually be in the Wait that waits for 11PM. Any idea why the rule is labeled Repeating?

If I might ask....why are you repeating the off commands to those devices at all? One command of Off should be enough for that many devices at once. I've turned off many more at once and not had a problem. If you are having to issue multiple commands, that leads to a problem with your mesh. Turning off 4 devices should NOT take more than one attempt.

So, rather than fix the repeating, let's take it out since you shouldn't need it at all and work on why the commands aren't going to your devices. :slight_smile:

I agree it shouldn't be needed but without it I wind up having devices that don't actually turn off. You're probably right it is a mesh issue but I'm not entirely sure what to do about it. I have about 60zwave devices that are all wired so they should be repeaters. You can't go more than 10ft in any direction within my house without there being another zwave device near by. I've done numerous zwave repairs, etc. I agree this is a hack, but it's the best I've come up with so far. If you have other suggestions I'm happy to give it a try,.

Regardless though it still shouldn't show "Repeating" :slight_smile:

With 4 devices in one command they all don't turn off? Really? Are they reporting that they turned off to the hub but are actually not turning off? Are you using the right driver for each of them (z-wave vs z-wave plus)? I have never seen a set with only 4 devices miss a command. If the hub couldn't do that we'd be in big trouble.

Have you refreshed the web page you are looking at recently? Have you looked at the rule properties page (gear icon) to see if there truly is a scheduled job?

Sorry, some shut off so it's definitely running the rule, just some don't. As a note two, it's not actually 4 devices, the Window Lights is actually a group 5 outlets and the Outdoor Lights is a group of 4 outdoor switches so it's actually 14 devices being turned off. As far as I know I'm using the right drivers. They are Generic ZWave Smart Switches for the outlets (they are GE/Jasco ZWave Plus devices) and Generic Z-Wave Outlet for the outdoor switches (They are GE/Jasco outdoor ZWave Plus devices). I don't see separate drivers for zwave plus?

I'm not sure if the Z-wave outlet driver is z-wave or Z-wave plus. The compatible devices list doesn't use that driver for any of the supported GE devices. Since it is a z-wave plus device, i would try using the Generic Z-wave Smart Switch driver instead. I know that is for z-wave plus devices.
Z-wave Plus = Smart driver in hubitat.

Did you check the rule's properties page?

Yes it's scheduled. So interestingly it looks like a lot of GE/Jasco devices are using a non-Smart driver. I'm thinking that could be impacting the mesh? I have a bunch of light switches that appear to have detected as a generic outlet instead of a smart switch.

No, it would not impact the would mean that the commands that are being issued to the device are not correct and that the switch is actually turning off and not showing that it is or just not turning off at all. If all your GE/Jasco are Z-wave Plus devices, they should be using the Smart Dimmer /Smart Switch drivers. I don't know about the outdoor module...that's not on the supported devices list. But changing it couldn't hurt. Just make sure you hit configure after changing the driver.

So I think I'm explaining poorly. It works "sometimes" if it were the wrong driver and therefore sending the wrong commands wouldn't it never work?

Not necessarily. I was using the wrong one for my z-wave plus dimmer and it would occasionally not report digital changes correctly in Hubitat. The dimmer would change but the level in hubitat would be wrong. And it was NOT consistent.

Ok, I'll make the change and see. Thanks for the help!

Make sure you click configure after changing driver and saving.

1 Like

Just curious since now you guys got me thinking. This device is ZWave Plus but the compatibility list says to use the non-smart driver:

Pull up the device and confirm you see 0x5E as that is the Zwave Plus cluster:

If yes change the driver and give it a try. You can always change it back.

1 Like

Like I said, I wasn't sure that whether the Z-wave outlet driver was for Z-wave plus or not. But I know that that the Z-wave Smart Switch driver is. If both use the on-off cluster the same, which they should, then the on-off part wouldn't be affected. The only thing that might would be energy reporting possibly. But it would help to figure out why your devices are not responding correctly.