Rule Machine issue w/ 703

Seems familiar. I did see this when I accidentally entered a time of off of 2.5 seconds in RM, and had to delete my Rule and build it again, but I've never seen this when trying to create a new rule. This has just occurred after updating to 703. Anyone else seeing this? Suggestions? Should I roll back to 702 and try the 703 update again?

I have tried rebooting. I'll try a complete shutdown and restart next.


Restore from backup and reinstall, I’d suggest.

Usually an error will be thrown in live logging. That might help clue in to what caused it. It shouldn’t take down the Parent though…

1 Like

I just upgraded to v703 and Rule Machine is “alive” when I ener into it… offers the usual menu to create rules, etc.

app:72018-03-15 19:23:41.532:errorCannot invoke method size() on null object

Will attempt restore and reinstall now. Thanks

Unfortunately no change. I’ll contact support via email. I didn’t understand that both restore methods only restore the database, not the previous firmware build.

Try removing Rule Engine, and then reinstalling, THEN restoring.

Good suggestion, but I can't remove RM because the option does not show up


Go back to the App List and click the i in a circle?

Thanks. This is the first issue I’ve had with an app. Appreciate your help.
I removed RM via the i, reinstalled and it works. But, when I restore any of my database backups, the problem reoccurs. Some rule in my database must be corrupt and the issue is only appearing under RM v2.4.0 in firmware 703. Anyway, restoring to 702 database wouldn’t have been acceptable for me, even if it did work, because when I do that, I don’t get the new Zone Motion Controllers app.

Looks like my only option is to rebuild my Rules :neutral_face:

Hope we can get Duplicate, Backup and Restore of individual rules in the future. That would help us find corruptions and eliminate them so we only have to rebuild a single rule.

Sent you a PM. We have another way to restore the previous firmware and that backup should restore to that version.

Do you have any idea what you were doing when this first popped up. Can you shed light on the specific steps that preceded the above screenshot? Did you have any Custom Commands installed previously?

I may be able to figure out a way for you NOT to have to rebuild all of your rules, but I need more info. Also, if you could show a screenshot of the App information page for Rule Machine (that the circle i brings up), that would be of help also.

Thanks Bruce. I don't have that many rules built at this point, so it's not a big deal for me, but if you want me to help you troubleshoot so if other encounter this and DO have a lot of rules, they might benefit, then I'm happy to help.

Yes. Saw the notice for update to 703 on the forum, so updated and then went right into RM to try out the new Fade Dimmer to Level over Time option and was halted right away by what you see above.

I'm new to RM and don't understand what you mean by "Custom Commands".

Here's the app info. Was chatting with @bobbyD about this. Something odd. Maybe something I did wrong when I was just beginning to play with RM. I don't understand why that bulb [Dining Room Light 1] is in use by the RM app. It is a light that is used in a few of my rules, but I don't understand why it's showing up there.

Thanks. I think your best bet is to remove RM completely. Upgrade to latest build. Start over with RM. I don’t know what happened, and I can’t reproduce your problem.

I don’t understand why that bulb [Dining Room Light 1] is in use by the RM app. It is a light that is used in a few of my rules, but I don’t understand why it’s showing up there.

Those three settings are from the custom commands menu. On my installation they are all the same as my last selection.

Could it be one rule causing issues? Possibly remove them one by one until the error goes away. Then restore again and remove the one problem rule? I guess if get to the point where they're all removed, it's some larger issue and better to start over anyways.

Unfortunately, it’s a larger corruption in my database. Tried the one by one removal method, but after testing each time I removed one, and once they were all gone, the issue remained until I removed and reinstalled RM.

I’m almost done rebuilding them. I discovered two of the rules contained a device that I had renamed, but it was still specified for refresh. I tried removing those two rules, backing the profile w/o the two rules, reinstalled the RM app and then restored the backup with only my other rules, but it did not help.

It’s for the best. I discovered the issue that I had missed and I think I have found a bug while rebuilding my water sensor rule.

Found an issue when I was building a water sensor rule. After defining the rule, i get blank fields when I try to go back in to edit. See the example that follows (first image is after the rule is defined. second image is when an attempt is made to edit the rule).

Lighting rules don't exhibit this issue. I'm only seeing it with the water sensor rule. I tried deleting and recreating the rule and it behaved the same way the second time as well.


When you have a Rule with only a single condition, Rule Machine skips actually filling in the rule, as it is a trivial rule. So the blank fields you see are normal. You could fill it in if you want, but it doesn’t matter.

I was having issues also after the update. I couldn’t even open the rules. It would open a blank page with a title of Rule Machine as above and that was it. Ended up having to remove RM and then reinstalled it, fixed all. Including the issues I was having where RM wasn’t controlling a couple of my devices with between time rules. Not sure if it was the update or if I had an issue before that and the update just shut it down.