Rule Machine bug with valve open/close action

Mine got messed up with the last firmware update as well but not the same as yours.
Mine messed up the Rule Machine app. Support was able to fix most of it.
The only issue I have noticed now is my Rule Machine rules will not activate (open/closed) any valves.
I changed the water valves device handlers to generic zwave switch and just used on and off now.
Valves (open/closed) worked fine in Rule Machine before this update.
Valves (open/closed) still worked in other Hubitat apps fine just not Rule Machine.
though I may be able to use on and off with my old water valve device handler instead of open and close. Will try when I get home tomorrow.

sorry to hear. for me this is the part i like least.

We can look into this. Nothing has changed in Rule Machine as to how it deals with valve open/close.

When you say that "Support was able to fix most of it", which part did we not fix?

So far this is all I have found not working
I noticed the rule was not working for the last week but just today figured out why.

"Valves (open/closed) worked fine in Rule Machine before this update."

What is not working about it? Could you show the rule in question? Can you operate this valve from it's device page with open and close?

Nevermind. There is a bug. I just found it. Fix in next release.

1 Like

i need to start quantifying my hub hanging post upgrade as an RM issue to get a quicker fix. :slight_smile:

yes from it's device page it works fine (open/close or on/off).
from using the "Hubitat simple lighting" app it works as a valve (open/close)
I am at work now will not be able to get a screen shot until I get home tomorrow.
I removed all apps from hub and then rebooted the hub and then re-installed Rule Machine.
To be sure there were no conflicting apps or rules.
Tried a simple rule - turn a switch on then open valve
didn't work.
changed the valve to a switch and then changed the rule from open valve to turn on
works fine

I have since restore my Hub from a backup to get all my apps and rules back and changed my rules that use valves from open to on.
everything working fine now.
I should have tried the on/off from my water valve device handler in the rule before changing the DH
Will try it tomorrow but I suspect it will work fine.

The really odd thing was Rule Machine would randomly fire
(usually delayed 5 minutes or so, not part of the rule) the valve open using old rules I had made before but when I tried to create a new rule it never opened the valve (I only tried for a few hours).

Perhaps you missed my comment above. I have found the bug with Rule Machine about valves. Open/Close Valve will be fixed in the next release.

1 Like

yes at work and missed your post

no I think he just likes me more!

1 Like

is your name RM? :wink: