Rule Machine adding NULL to command

It's been 20 years since I did any programming and after many many attempts I finally finished my one nested rule to control my air heater / AC unit. When I was done I noticed that RM4 had added NULL in a few places. I tried to remove them, but I wasn't allowed to remove NULL (which makes some sense I guess).

Why where the NULL commands added (in two places) to the ON string?

(ON, , , ) => (ON, NULL, NULL, NULL)

I ran the rule and it produced an error code. I am not tech savvy anymore enought to make any sense of it, but it mentions "null object"? Can you make any sense of it?

After many attempts at controlling my mini-split AC / heating system with RM, I decided it was easier to write an app. Feel free to use my miniSplit app.

You will need to either rename your rules to conform to those in the app, or adjust the rule names in the app, and perhaps converting it from F to C. It works in conjunction with a Virtual Thermostat. Despite comments in the app: heat, cool, fan, and dry functions are working.


Thanks for sharing. Apreciated.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.