Rule Machine 5 has a bug with group bulb dimmer

I noticed something strange, I have rules set up for all sorts of things, and rules that involve group bulb dimmers do not run if they are stacked. I can separate out each dimmer group and interact with it that way, but when I add more than 2 or 3 on a row it just does not run on the last few. Example:

I have a rule that runs at 7:00AM every day. It turns on some lights and sets color temp.

Color Temperature: Basement Lights, Dining Room Lights, Hallway Lights -> Level: 100

Basement and Dining Room Lights run fine, Hallway does not. I split out Hallway Lights as a separate line item in the rule and suddenly it works. Each dimmer group works fine on their own, its just when they are stacked in a rule that they fail pretty consistently. Anyone else have this issue, and if so, is this being worked on?

Thanks!

Are you use this is a Rule Machine bug and not just an issue with your network getting so flooded with commands that devices end up missing or ignoring them? Enabling the "metering" option in the Group app for your groups may help with this a bit by allowing you to space out the commands by the specified number of milliseconds. If you're already using something like Zigbee Group Messaging inside each group, this isn't likely to help as much, if at all, and in that case another option is to meter the commands sent by Rule Machine itself. You can't do that with the "built in" actions, but you could use a custom action, run the on() command on the scene activator device (which activates it, same as the built-in action), and turn on the "metering" option there. Custom commands allow you to do this when you select multiple devices.

So, turn on metering in rule machine itself? I looked at custom commands and I can interact with the Group device but it doesn't give me the option to interact with meterMs...many thanks!

Ooops, just checked and it's not there yet! It is something they have said is coming in the next release, howeever. In the meantime, you could consider Groups (if you aren't already using them) or separate actions for eschew device of couple with a small delay action in between, which would get the dame outcome--just to see if that helps.

Haha!! I don't feel so bad now. I would split them out but it doesn't look nearly as nice with a wall of rules...Im all for simplifying things but if the groups are going too fast then ill have to split them. Side note, you said zigbee group messaging would not allow metering to work, but im assuming that if I disabled group messaging, my lights would most likely popcorn.

Yeah, Group Messaging would probably result in more popcorning, and leaving it on should also reduce the bigger problem overall, I'd say (though you can try it both ways). You could still try metering, as if the app needs to send more than one command to the group to achieve its goal, it would still meter those.

You could also make a group of groups and then enable metering within that larger group, or make yet another group that contains just these devices, and in either case enable metering there (or in the last case, Zigbee Group Messaging--won't work if nested, though it will just ignore the option if it can't be done, so it won't hurt anything). But that approach might get messy if you use different "groups" in every app.

I tried breaking them out into their own rules and still half failed, the switch turned on so it DID run, like you said, Im sure its zigbee network related. Something is happening too fast. Have they said when metering commands in rules will be here? Sounds like that would fix my issue, though my next step will be to make a "group" of groups as you suggested and enable metering, and if that doesn't work ill insert a manual delay in each rule but that's going to be ugly.

Edit: That's a no-go on the grouping of groups, you can't control color temp or levels you can only turn it on or off. Guess Ill disable all my rules and wait for the metering update :slight_smile: seems like I don't have THAT many things firing off, I would have thought others would have this issue as well.

Sounds like you choose "Switch" instead of "Bulb" for "group device type" in the Groups app? You should be able to (but would need to re-create the group to get this option to be change-able again).

The issue with commands going out to your network "too fast" was just a guess on my part, but anecdotally I have found that slowing this kind of thing down a bit can help. I assume it's coming in 2.3.1 for custom commands in RM, but we don't know when that release will be yet. In the meantime, you can, again, do separate actions for each and just put a delay or wait between them (or possibly use this group of groups, with metering enabled, in just a single action).

Download the Hubitat app