Room Lighting - turning on bulbs broken?


This seems to have started recently - I have a group of two Zigbee RGB bulbs, and while they can each be turned on individually, when grouped together in Room Lighting, RL will not flip their switch to "On" when activated, and if I use the "On" function in the activator device, it does nothing.

This is what's in my logs when I click "Activate" in the RL group or "On" in the activator device.

Here's the RL group itself:

Note that the activator device works just fine to change colors and turn the bulbs off, just not on. This is on on a C8.

Your logs show setColor command being sent to each of them, and that is what should happen. Try that from the device page and see if the light turns on. This seems like a device issue, not an RL issue.

1 Like

A SetColor does not turn them on from the individual device page, either.

This literally just started last week (I believe on the upgrade to These lights have been working fine, in the same rules, for at least two years. It seems like before an Activate would send an On and it no longer does.

They are Sengled Element Color Plus (E12-N1E) bulbs.

Turning off Color Pre-Staging on the underlying bulb devices in HE fixed it. Not sure if/when this behavior changed.

1 Like

wow. for a few days I've been trying to figure out what I broke in 2 RL's. disabled 'pre_stage' and it worked immediately. Another thing for me to stay away from.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.