Room Lighting Questions

I have three room lighting setups. They range from 730am to 1201am

All three of these are controlling more or less the same devices. Some light colors change and some lights are cut on and off.

Everything is set up to activate on a specific time.

Here are my rule pages.

Having said all this, the first two time periods work great. It’s only when the 730pm transition is where things fail. Only one device stays on and that is the Hue cabinet lights. Everything else stays off.

And no I did not have logs set up. I will enable both in each if I need too.

Is there a better way to do this?

Am I not understanding how this app works?

Does every device need to be in all three?

You need to setup the lighting periods and use a single Room Lights instance. When you set up the periods, you can put the variations in for each period.

Ok will look at that tonight. Thanks.

Ok I went and created a new Room lighting rule that varies lights based on Hub Mode.

Loaded Mode Manager and set times for modes.

Anything else I need to look at? Just finished so I have to watch the modes to see what is happening.

This should work especially if you plan on using modes in other Room Lightning or rules. If you wanted to just use time in this specific instance, change it to time periods rather than modes in Room Lighting.

Well I have everything set, but it will not change at the times it is supposed too.

My activation is on the time changes.

I don't even see that option to activate on time periods start? You said above you were using mode but your screenshots seem to show time periods? Which are you using?

Maybe select activate when mode becomes and select all your modes? Assuming you want this on all the time?

You also will want this option (from Activate Light Options) so it will change when the mode changes.

EDIT: If you are using time period you have the same option for that to force it to change when the period changes. Turn this On.

1 Like

@jtp10181 is correct. You need the adjust lights as time period changes option to be selected. Without it, your lights will stay the same when first turned on and never switch how you want.

Thank you both so much. It is flawless now. I was missing one part.

This was the key. I’m went back to using modes instead of time also.

Thanks for the help and your patience.

Now on to the color tweaking!