Room lighting not turning on after HomeKit change

Hello,

I updated my hub and this new room lighting app is amazing except for one point.
When I enter my bathroom I have 2 motion detector devices that would trigger an automation to turn on the lights.
But if for any reason I turn off the lights manually (homeKit or Philips hue) I will have to wait 5 or 10min for Hubitat to turn on the lights via the motion devices.

The image attached is my automation, fairly simple:
Turn On if movement detected
If no more movement turn off

Any help to fix this would be appreciated.

Thanks

This happens with my hue lights and room lighting automations as well. I got around it with aurora dimmers directly connected to the hue hub. Never actually figured it out though. I’d love to hear how to fix this

So I think you are saying that turning the light off manually does not reset the RL instance to allow it be activated again?

What happens is the RL instance is still "active" until the motion times out as you have programmed. When the RL is active it will not re-activate unless you allow it do so.

In the means to turn off, in the extra options, set this setting to your switch.
image

That will cause the RL to become inactive when the switch is tuned off and ready for motion to trigger it again.

Hello,

This is exactly my issue!
I do not turn these off using a switch but Siri from my phone (a scene to turn all the lights out).

So the switch idea does not work as I do not have a specific switch that’s would turn them off, it is HomeKit connected to hue.

Will there be another way to revert the motion detector or to deactivate the automation ?

Thanks

Is there more than one light? If it turns off via Siri it will still turn the switch off in Hubitat if you have it all setup correctly.

@user4040 please post a screenshot of the entire RL setup, use two screenshots if needed. So I can see what all is involved.

What do you do if there’s more than one light?

You can put multiple switches in that option I showed above, I think it will wait for them all to be off if I remember correctly from my testing. Its probably in the docs somewhere.

4 lights are involved.
I did not included your first solution as I do not have a switch (or a virtual one).
Do you have any recommendations on his to setup w switch that will follow the state of the bathroom or the state of each bulb?

Got my promotion: here are the screenshots



The easiest solution I think will be to allow activation when already active.
In the means to Activate >> Activation Options >> Additional Options
Select "Activate even if already partially activated"

Will look like this once back at the main RL screen:
image

There is one downfall of this with motion activation, if you are in the room and adjust the lights, and the motion sensor reports "active" again for whatever reason it will activate the RL again and set the light back to the RL settings.

Thanks for the help.
I will try it out, otherwise I’ll just use the hue app to program it.

It is too bad that there is no option to do it better.

But your help was really precious.

Also note that those 4 bulbs also have switch capability. So you can add any of them to the 'switches that determine all lights are off' section. If the behavior of the option requires all to be off to re-trigger you could set up a single virtual switch that gets turned off by any of the bulbs via a separate rule.

Could you give me more info on how to setup the virtual switch?

That looks like an interesting path

From the Devices page, choose Add Device, then Virtual Device. There are several options, you just want a 'Virtual Switch'. Then you control/automate it in the same way as any other 'real' switch.

Adding the motion controlled lights to the “switches that determine if all lights are off” fixed this exact problem for me.

It’s not referring to physical switches on the wall, but rather what Hubitat sees as an on/off switch with the lights. Go take a look in that section, the lights your RL instance are controlling should be selectable

1 Like

Download the Hubitat app