Room lighting not advancing through the days of the week

In Room Lighting app, I would like the Sengled zigbee colour bulbs to come on at 8pm every night of the week in a different colour e.g Monday blue, Tuesday green, etc. instead the app shows one day and colour and will not advance to the next day.

In am running C-8, Version I have tried the 'Means to Activate' as days of the week schedule and 'Adjust Lights on Time Period Change' with no success.
Could I be making a mistake on the ' Set Up Lighting Periods or Re-Capture Devices' page. I have chosen the 'Select Day Groups' as the days of the week and selected 'Time Periods' as the days of the week and times at 8pm for every day. Then I setup a table for everyday with a different colour, checking both 'Act' and 'Off'. Bulbs come on at the right time and go off at the right time.

Any help would be greatly appreciated.

Thank you,


Could you post a screenshot of your RL setup?

Sure, here it is..

Do you have the tables filled out properly under the schedule?

You can change your means to activate to "activate at time period starts" instead of manually setting the day/time as a trigger.

setting up day groups is in the documentation. Room Lighting | Hubitat Documentation.

The way you have it set up, ALL days would be the same time periods (as indicated by the single row with M, T, W, Th, F, Sa, Su checked)

When you have the day groups set up, you need to keep unchecking each day until it gets onto it's own row.

Once you do that, it should look like this

Multiple Day Groups

Then you create a new time period and name it what you want. I used "8PM"

Then you set the time for each day by clicking the set time (Not sure this is needed if you are just going to activate it at 8)

Create Time periods and set time

After that, you will have different configurable settings for each time period and day you have set up. Just click the number under level, temp, or in your case color to change them

Multiple Settings

1 Like

Thank you all very much for your help.

tray_e: I tried your setup, I will let you know what happens tomorrow night at 8pm.
FriedCheese2006: I set means to activate to 'activate at time period starts'.
Thank you as well aaiyar.

You guys are great.


The setup worked very well tonight, lights came on at correct colour for the correct day. Again I want to thank you all for your tremendous help..

I love Hubitat...


Download the Hubitat app