Room Lighting entities can't be edited if the room is renamed (?)

I think I discovered a (minor?) bug in the Room Lighting app (I'm running Platform Version

I renamed a room in the ROOMS tab, and that seem to make any Room Lighting apps un-editable (although the automations still seemed to activate, so, just a UI/web issue?)

After renaming the room, I tried to edit the RL apps for that particular room, and got the error the error:

I'm guessing that the drop down for the "Rooms to Automate" pick fails if it can't find the room name any longer, hence the "Cannot get property ID from null object".

I was able to reproduce this by creating a room Lighting automation for my upstairs bath (that didn't have any other automations :wink: ), then renaming the room to "Second Floor Bath", and then when you try to edit the Room Lighting automation, it produces the error.

Ended up doing a work around of removing the RL automation using the "gear" icon, and then recreating it under the "new" room name. (In hind sight, I probably should have tried renaming the room BACK to what it was before. :man_facepalming: )

Anyone else seen these behavior before?

1 Like

I am seeing the same behavior. As soon as I renamed the room back to what it was before then I could open the RL app again.

Error message in the logs:
java.lang.NullPointerException: Cannot get property 'id' on null object on line 92 (method mainPage)

If I export the JSON and change the room name and import it back then it works as well.

@bravenel Please fix this bug

1 Like

I will look into it. Yeah, it's definitely not handling that properly.

This will be fixed in an upcoming release.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.